summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-09-12 23:47:24 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-12 23:56:34 +0200
commit1fda01ef4222d71627572074fc691672e788a678 (patch)
treebc6ca9930f357ffbae52a52d782fdbfbf8b9f100 /gnu/packages/texinfo.scm
parent960c40de21650368021b20c78b79101bce022b51 (diff)
downloadguix-patches-1fda01ef4222d71627572074fc691672e788a678.tar
guix-patches-1fda01ef4222d71627572074fc691672e788a678.tar.gz
gnu: texinfo: Add 6.5.
* gnu/packages/texinfo.scm (texinfo-latest): New variable.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 6ec2bb8e9b..8c33023bd0 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
@@ -30,6 +30,7 @@
#:use-module (gnu packages ncurses))
(define-public texinfo
+ ;; TODO: Merge with 'texinfo-latest' on the next core-updates.
(package
(name "texinfo")
(version "6.3")
@@ -62,6 +63,19 @@ their source and the command-line Info reader. The emphasis of the language
is on expressing the content semantically, avoiding physical markup commands.")
(license gpl3+)))
+(define-public texinfo-latest
+ ;; TODO: Turn this into 'texinfo' on the next core-updates cycle.
+ (package (inherit texinfo)
+ (version "6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/texinfo/texinfo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0qjzvbvnv9003xdrcpi3jp7y68j4hq2ciw9frh2hghh698zlnxvp"))))
+ (native-inputs '())))
+
(define-public texinfo-5
(package (inherit texinfo)
(version "5.2")