summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-31 11:00:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:23 -0400
commitff02979ed56fb046de3f9170820c4c5cdae419d1 (patch)
treeec1fc5ba88dacae61a5331a3bad91e5cab3ff562 /gnu/packages/tex.scm
parentce73cadd34b6e49a1e6fd0d7b98048e7867f799b (diff)
downloadguix-patches-ff02979ed56fb046de3f9170820c4c5cdae419d1.tar
guix-patches-ff02979ed56fb046de3f9170820c4c5cdae419d1.tar.gz
gnu: Add texlive-stix2-otf.
* gnu/packages/tex.scm (texlive-stix2-otf): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8c31d131b6..c3129ebd60 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6445,6 +6445,41 @@ package supports pdfTeX (pdfLaTeX) and VTeX. With VTeX it is even possible to
use this package to insert PostScript files, in addition to PDF files.")
(license license:lppl1.3+)))
+(define-public texlive-stix2-otf
+ (let ((base (simple-texlive-package
+ "texlive-stix2-otf"
+ (list "/doc/fonts/stix2-otf/"
+ "/fonts/opentype/public/stix2-otf/")
+ (base32 "0i7rd1wn5jgm3gbi779gy78apz63w034ck4pn73xw6s10zgjzmgl")
+ ;; Building these fonts requires FontLab, which is nonfree.
+ #:trivial? #t)))
+ (package
+ (inherit base)
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'install 'symlink-fonts-to-system-fonts-prefix
+ ;; This is so that fontconfig can locate the fonts, such as
+ ;; when using xetex or xelatex.
+ (lambda _
+ (let ((system-fonts-prefix (string-append #$output
+ "/share/fonts")))
+ (mkdir-p system-fonts-prefix)
+ (symlink (string-append
+ #$output "/share/texmf-dist/fonts/opentype"
+ "/public/stix2-otf")
+ (string-append system-fonts-prefix
+ "/stix2-otf")))))))))
+ (home-page "https://www.stixfonts.org/")
+ (synopsis "OpenType Unicode text and maths fonts")
+ (description "The Scientific and Technical Information eXchange (STIX)
+fonts are intended to satisfy the demanding needs of authors, publishers,
+printers, and others working in the scientific, medical, and technical fields.
+They combine a comprehensive Unicode-based collection of mathematical symbols
+and alphabets with a set of text faces suitable for professional publishing.")
+ (license license:silofl1.1))))
+
(define-public texlive-stmaryrd
(let ((template (simple-texlive-package
"texlive-stmaryrd"