summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 11:54:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:16 +0200
commitf5a6af42b955c21da0b62d0ac8240a26160e6c52 (patch)
tree1ac9eba174ab670afbdaa1b5ee3b82c363bc63bc /gnu/packages/tex.scm
parent4eebd2cdde6baa1d5cfaeb31a0bb03149e8db1d8 (diff)
downloadguix-patches-f5a6af42b955c21da0b62d0ac8240a26160e6c52.tar
guix-patches-f5a6af42b955c21da0b62d0ac8240a26160e6c52.tar.gz
gnu: Add texlive-latex-xcolor.
* gnu/packages/tex.scm (texlive-latex-xcolor): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 640f8fd4db..b5612be243 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -946,6 +946,30 @@ keyval, and lscape.")
(license (list license:lppl1.3c+
license:cc0))))
+(define-public texlive-latex-xcolor
+ (package
+ (name "texlive-latex-xcolor")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "xcolor"))
+ (sha256
+ (base32
+ "01n613s7bcrd2n4jfawm0k4nn2ny3aaifp2jjfif3lz4sbv31494"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/xcolor"))
+ (home-page "http://www.ctan.org/pkg/xcolor")
+ (synopsis "Driver-independent color extensions for LaTeX and pdfLaTeX")
+ (description
+ "The package starts from the basic facilities of the colorcolor package,
+and provides easy driver-independent access to several kinds of color tints,
+shades, tones, and mixes of arbitrary colors. It allows a user to select a
+document-wide target color model and offers complete tools for conversion
+between eight color models. Additionally, there is a command for alternating
+row colors plus repeated non-aligned material (like horizontal lines) in
+tables.")
+ (license license:lppl1.2+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")