summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-12 14:17:18 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-12 14:21:23 +0100
commite698843442b34185864f9bed6dc7b75b7254f29e (patch)
treeccb5a75e1c53659d977c40143a349920ce06d51a /gnu/packages/tex.scm
parentac3bf4e4da58e985f012d216b2faf36434cdf967 (diff)
downloadguix-patches-e698843442b34185864f9bed6dc7b75b7254f29e.tar
guix-patches-e698843442b34185864f9bed6dc7b75b7254f29e.tar.gz
gnu: Add texlive-newtx.
* gnu/packages/tex.scm: New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dfc92c3174..47bfde55b4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7978,3 +7978,31 @@ as the default text font. The @code{fontaxes} package is required for
use with [pdf]LaTeX.")
(license (list license:silofl1.1 ;for Cabin
license:lppl)))) ;for support files
+
+(define-public texlive-newtx
+ (package
+ (inherit (simple-texlive-package
+ "texlive-newtx"
+ (list "/doc/fonts/newtx/"
+ "/fonts/afm/public/newtx/"
+ "/fonts/enc/dvips/newtx/"
+ "/fonts/map/dvips/newtx/"
+ "/fonts/opentype/public/newtx/"
+ "/fonts/tfm/public/newtx/"
+ "/fonts/type1/public/newtx/"
+ "/fonts/vf/public/newtx/"
+ "/tex/latex/newtx/")
+ (base32
+ "0rqjj33m6xkhrjzjhf24kxdg61az5sqsbcl0m7xqkf4akqybn22d")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/newtx")
+ (synopsis "Repackaging of the TX fonts with improved metrics")
+ (description "The @code{newtx} bundle splits
+@code{txfonts.sty} (from the TX fonts distribution) into two
+independent packages, @code{newtxtext.sty} and @code{newtxmath.sty},
+each with fixes and enhancements. @code{newtxmath}'s metrics have
+been re-evaluated to provide a less tight appearance and to provide a
+@code{libertine} option that substitutes Libertine italic and Greek
+letters for the existing math italic and Greek glyphs, making a
+mathematics package that matches Libertine text quite well.")
+ (license license:lppl1.3)))