summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-15 19:07:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:48 +0200
commitdfdc002c9bf86270941823a96abded0aa5d44088 (patch)
treef1771696734e97055fc1370aa7bbf811ccd8b9fe /gnu/packages/tex.scm
parent2b25469476fd90d624f80189bb11ca32df8ee811 (diff)
downloadguix-patches-dfdc002c9bf86270941823a96abded0aa5d44088.tar
guix-patches-dfdc002c9bf86270941823a96abded0aa5d44088.tar.gz
gnu: texlive-bin: Include scripts.
* gnu/packages/tex.scm (texlive-bin)[inputs]: Add texlive-scripts. [arguments]: Let fmtutil.pl reference scripts directory.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f66fddfe02..a1e12df6a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -271,6 +271,20 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
(build-system gnu-build-system)
(inputs
`(("texlive-extra-src" ,texlive-extra-src)
+ ("texlive-scripts"
+ ,(origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/scripts/texlive"))
+ (revision %texlive-revision)))
+ (file-name (string-append "texlive-scripts-"
+ (number->string %texlive-revision)
+ "-checkout"))
+ (sha256
+ (base32
+ "0wrjls1y9b4k1z10l9l8w2l3yjcw7v7by2y16kchdpkiyldlkry6"))))
("cairo" ,cairo)
("fontconfig" ,fontconfig)
("fontforge" ,fontforge)
@@ -386,6 +400,13 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
(apply unpack (list #:source texlive-extra))
(apply patch-source-shebangs (list #:source texlive-extra))
(invoke "mv" "tlpkg" share))
+ (let ((scripts (string-append share "/texmf-dist/scripts/texlive/")))
+ (mkdir-p scripts)
+ (copy-recursively (assoc-ref inputs "texlive-scripts") scripts)
+ ;; Make sure that fmtutil can find its Perl modules.
+ (substitute* (string-append scripts "fmtutil.pl")
+ (("\\$TEXMFROOT/") (string-append share "/"))))
+
;; texlua shebangs are not patched by the patch-source-shebangs
;; phase because the texlua executable does not exist at that
;; time.