summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2022-07-16 15:28:07 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:27 +0200
commit96e50a219d206436ed5d06cfdec88f175b992530 (patch)
treefc87de7c4cb86d98e7eab3bf7e007f12ed7d6415 /gnu/packages/tex.scm
parent772db83faaebee82f6462878d1b3ac21b248e918 (diff)
downloadguix-patches-96e50a219d206436ed5d06cfdec88f175b992530.tar
guix-patches-96e50a219d206436ed5d06cfdec88f175b992530.tar.gz
gnu: Add texlive-pgfgantt.
* gnu/packages/tex.scm (texlive-pgfgantt): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9cfe673695..15f411da56 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11121,3 +11121,23 @@ lines in a document. Package options include @code{singlespacing},
can be changed as required with the @code{\\singlespacing},
@code{\\onehalfspacing}, and @code{\\doublespacing} commands. Other size
spacings also available.")))
+
+(define-public texlive-pgfgantt
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-pgfgantt"
+ (list
+ "doc/latex/pgfgantt/"
+ "source/latex/pgfgantt/"
+ "tex/latex/pgfgantt/")
+ (base32 "0bm034iizk4sd7p5x7vkj7v57dc0bf2lswpsb32s4qlg4s7h6jqz")
+ #:trivial? #t))
+ (propagated-inputs (list texlive-pgf))
+ (home-page "https://ctan.org/graphics/pgf/contrib/pgfgantt")
+ (synopsis "Draw Gantt charts with TikZ")
+ (description
+ "The @code{pgfgantt} package provides an environment for drawing Gantt charts
+that contain various elements (titles, bars, milestones, groups and links).
+Several keys customize the appearance of the chart elements.")
+ (license license:lppl1.3+)))