summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-03 13:42:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-03 15:36:13 +0200
commit962be3af65569d113941d64e0413bd347cd93dd5 (patch)
tree6f1d78c027b6a040af72781d5bf1ffed79bac034 /gnu/packages/tex.scm
parentf0eb053dac8273416ab24541b85617d79dbae134 (diff)
downloadguix-patches-962be3af65569d113941d64e0413bd347cd93dd5.tar
guix-patches-962be3af65569d113941d64e0413bd347cd93dd5.tar.gz
gnu: Add texlive-sectsty.
* gnu/packages/tex.scm (texlive-sectsty): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bcb7f168fb..bd22e065ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -8056,6 +8056,33 @@ basic Adobe Type 1 fonts (Times, Helvetica and Courier) in LaTeX using
LY1 encoding.")
(license license:lppl1.0+)))
+(define-public texlive-sectsty
+ (let ((template (simple-texlive-package
+ "texlive-sectsty"
+ (list "/doc/latex/sectsty/"
+ "/source/latex/sectsty/")
+ (base32
+ "08m90j7cg6w46vnwgsp10clpj4l6c9a6l8dad20q3mnd32l84hbl"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/sectsty")
+ ((#:build-targets _ '())
+ ''("sectsty.ins"))
+ ((#:tex-format _ "latex") "latex")
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/sectsty")))))))
+ (home-page "https://www.ctan.org/pkg/sectsty")
+ (synopsis "Control sectional headers")
+ (description "This is a LaTeX2ε package to help change the style of any or
+all of LaTeX's sectional headers in the article, book, or report classes.
+Examples include the addition of rules above or below a section title. ")
+ (license license:lppl1.2+))))
+
(define-public texlive-kastrup
(package
(name "texlive-kastrup")