summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-17 16:18:39 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-17 16:21:28 +0100
commit94ca1e19b3ad8c9366a5e14a1fa1bbacca711a92 (patch)
tree85ca28f496c2a6fb393225419b7eb51d19e31c8c /gnu/packages/tex.scm
parent9911dc10e2faed7f26dc115a0722803a479dbd2a (diff)
downloadguix-patches-94ca1e19b3ad8c9366a5e14a1fa1bbacca711a92.tar
guix-patches-94ca1e19b3ad8c9366a5e14a1fa1bbacca711a92.tar.gz
gnu: Add texlive-units.
* gnu/packages/tex.scm (texlive-units): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 35f2049dbf..78dd37733d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7401,3 +7401,21 @@ things to do later, in a simple and visually appealing way. The
package takes several options to enable customization and finetuning
of the visual appearance.")
(license license:lppl1.3+))))
+
+(define-public texlive-units
+ (let ((template (simple-texlive-package
+ "texlive-units"
+ (list "/doc/latex/units/"
+ "/tex/latex/units/")
+ (base32
+ "1ia1vzy8dp7pdvmawwnmh9lmkajmpnnh62dixrjpb6mnxq118bfd")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/units")
+ (synopsis "Typeset physical units and fractions")
+ (description "@code{units} is a package for typesetting physical
+units in a standard-looking way. The package is based upon
+@code{nicefrac}, a package for typing fractions. @code{nicefrac} is
+included in the @code{units} bundle.")
+ (license license:gpl3+))))