summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-14 12:01:36 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-14 12:04:14 +0100
commit9153e12d737ee04c380809ab0598ad888f291a0b (patch)
tree2a8ca3a181ac3f895329bd2707846bc48da6fae2 /gnu/packages/tex.scm
parentf181ee1f424308618d5d8d2ae9afacc5f8ec7b73 (diff)
downloadguix-patches-9153e12d737ee04c380809ab0598ad888f291a0b.tar
guix-patches-9153e12d737ee04c380809ab0598ad888f291a0b.tar.gz
gnu: Add texlive-ly1.
* gnu/packages/tex.scm: New package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 317f1a8416..305d40178a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8033,3 +8033,25 @@ Type 1 and OTF formats, with supporting files as necessary.")
(license (list (license:fsf-free
"http://mirrors.ctan.org/fonts/xcharter/README")
license:lppl1.3))))
+
+(define-public texlive-ly1
+ (package
+ (inherit (simple-texlive-package
+ "texlive-ly1"
+ (list "/doc/fonts/ly1/"
+ "/fonts/enc/dvips/ly1/"
+ "/fonts/map/dvips/ly1/"
+ "/fonts/tfm/adobe/ly1/"
+ "/fonts/vf/adobe/ly1/"
+ "/tex/latex/ly1/")
+ (base32
+ "0wjyw0risgvrq97zfciglwy1f4msvfslln6pz0q8yzzx8wsv3zgq")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/ly1")
+ (synopsis "Support for LY1 LaTeX encoding")
+ (description "The legacy @emph{texnansi} (TeX and ANSI) encoding
+is known in the LaTeX scheme of things as @emph{LY1} encoding. The
+@code{ly1} bundle includes metrics and LaTeX macros to use the three
+basic Adobe Type 1 fonts (Times, Helvetica and Courier) in LaTeX using
+LY1 encoding.")
+ (license license:lppl1.0+)))