summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-16 13:16:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:49 +0200
commit8fee5067b28f82512621a389ea5cf12fa89ef354 (patch)
tree8c4f47c7cf10d28df299b81a32505e49ea75051b /gnu/packages/tex.scm
parent8bc9afeb9e63a473b29a440f04659171a032ee23 (diff)
downloadguix-patches-8fee5067b28f82512621a389ea5cf12fa89ef354.tar
guix-patches-8fee5067b28f82512621a389ea5cf12fa89ef354.tar.gz
gnu: texlive-tex-plain: Simplify.
* gnu/packages/tex.scm (texlive-tex-plain): Implement with SIMPLE-TEXLIVE-PACKAGE. [description]: Use full sentences.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 9 insertions, 27 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e1c1d173cf..dfd23ab7d6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1270,36 +1270,18 @@ incorporates the e-TeX extensions.")
(define-public texlive-tex-plain
(package
- (name "texlive-tex-plain")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/plain"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1xknlb3gcw6jjqh97bhghxi594bzpj1zfzzfsrr9pvr9s1bx7dnf"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/plain")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-tex-plain"
+ (list "/tex/plain/")
+ (base32
+ "1rrfay4d7lbyj02wlf23mwvbpjd160nwlgryx97hq1vb7dva4swr")
+ #:trivial? #t))
(home-page "https://www.ctan.org/pkg/plain")
(synopsis "Plain TeX format and supporting files")
(description
- "Contains files used to build the Plain TeX format, as described in the
-TeXbook, together with various supporting files (some also discussed in the
-book).")
+ "This package contains files used to build the Plain TeX format, as
+described in the TeXbook, together with various supporting files (some also
+discussed in the book).")
(license license:knuth)))
(define-public texlive-hyphen-afrikaans