summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 21:28:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:11 +0200
commit87b4360ee8eb5d0e374c5e8d50577332d9dd8a92 (patch)
tree5515ed1cb603c0dfbbe314ebb499b0e384a54794 /gnu/packages/tex.scm
parent86af0f2a342269b9a3f6b8084a9e8e5d6feb6eb8 (diff)
downloadguix-patches-87b4360ee8eb5d0e374c5e8d50577332d9dd8a92.tar
guix-patches-87b4360ee8eb5d0e374c5e8d50577332d9dd8a92.tar.gz
gnu: Add texlive-latex-acronym.
* gnu/packages/tex.scm (texlive-latex-acronym): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f8a79b9297..ea36c3dc2b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2555,6 +2555,29 @@ dvipng, but it also works when you are using PDFTeX for generating PDF
files.")
(license license:gpl3+)))
+(define-public texlive-latex-acronym
+ (package
+ (name "texlive-latex-acronym")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "acronym"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0jmasg40bk53zdd2jc8nc18jvdai3p2wmamy7hwli8gls4nf25qp"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/acronym"))
+ (home-page "http://www.ctan.org/pkg/acronym")
+ (synopsis "Expand acronyms at least once")
+ (description
+ "This package ensures that all acronyms used in the text are spelled out
+in full at least once. It also provides an environment to build a list of
+acronyms used. The package is compatible with PDF bookmarks. The package
+requires the suffix package, which in turn requires that it runs under
+e-TeX.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")