summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-09-05 00:26:26 +0200
committerJohn Darrington <jmd@gnu.org>2016-09-06 18:36:29 +0200
commit83457fe00efc12120fb2a41398b136353e0dcb51 (patch)
tree99bbc12983bb7642a7bf393cedbc51938dab10f8 /gnu/packages/tex.scm
parent274563e1f4b3ff89ad628e6318c43d3e8bc1aa66 (diff)
downloadguix-patches-83457fe00efc12120fb2a41398b136353e0dcb51.tar
guix-patches-83457fe00efc12120fb2a41398b136353e0dcb51.tar.gz
gnu: Add teximpatient.
* gnu/packages/tex.scm (teximpatient): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9dde8a9eab..c8114c2077 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -28,7 +28,9 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix utils)
+ #:use-module (guix git-download)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@@ -446,3 +448,44 @@ PDF documents.")
(description "Texmaker is a program that integrates many tools needed to
develop documents with LaTeX, in a single application.")
(license license:gpl2+)))
+
+
+(define-public teximpatient
+ (package
+ (name "teximpatient")
+ (version "2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/" name "/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0h56w22d99dh4fgld4ssik8ggnmhmrrbnrn1lnxi1zr0miphn1sd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ ;; Unfortunately some mistakes have been made in packaging.
+ ;; Work around them here ...
+ (replace 'unpack
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((srcdir "teximpatient-2.4"))
+ (system* "tar" "-xzf" (assoc-ref inputs "source")
+ (string-append "--one-top-level=" srcdir))
+ (delete-file (string-append srcdir "/book.pdf"))
+ (install-file (car
+ (find-files
+ (assoc-ref inputs "automake")
+ "^install-sh$"))
+ srcdir)
+ (chdir srcdir)))))))
+ (native-inputs
+ `(("texlive" ,texlive)
+ ("automake" ,automake)))
+ (home-page "http://www.gnu.org/software/teximpatient")
+ (synopsis "Book on TeX, plain TeX and Eplain")
+ (description "@i{TeX for the Impatient} is a ~350 page book on TeX,
+plain TeX, and Eplain, originally written by Paul Abrahams, Kathryn Hargreaves,
+and Karl Berry.")
+ (license license:fdl1.3+)))