summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-04 17:42:20 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 09:47:44 -0500
commit7b825087ecf1e1dbacdcac6e43492e5a792d41d6 (patch)
tree4a411b23fd1a79f92e1a7d686d61d5601f1123b5 /gnu/packages/tex.scm
parent56edfeec6c69fd54a4d6035138b081c529a334a4 (diff)
downloadguix-patches-7b825087ecf1e1dbacdcac6e43492e5a792d41d6.tar
guix-patches-7b825087ecf1e1dbacdcac6e43492e5a792d41d6.tar.gz
gnu: Add texlive-jknappen.
* gnu/packages/tex.scm (texlive-jknappen): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aad8d91d81..2cd93da983 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5377,6 +5377,56 @@ alternative version of the Kurier fonts. The difference lies in the absence
of ink traps which typify the Kurier font.")
(license license:gfl1.0)))
+(define-public texlive-jknappen
+ (package
+ (inherit (simple-texlive-package
+ "texlive-jknappen"
+ (list "/fonts/source/jknappen/"
+ "/fonts/tfm/jknappen/"
+ "/fonts/source/jknappen/"
+ "/fonts/tfm/jknappen/"
+ "/tex4ht/ht-fonts/alias/jknappen/"
+ "/tex4ht/ht-fonts/unicode/jknappen/")
+ (base32
+ "1v5wk5il41bddzr81h5636h3cjz0w1qann5g9garsb7qfch9fhws")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/jknappen")
+ (synopsis "Miscellaneous packages by Jörg Knappen")
+ (description
+ "This package contains a collection of macros by Jörg Knappen:
+@table @code
+@item greekctr
+New counterstyles @code{\\greek} and @code{\\Greek}.
+@item holtpolt
+Non-commutative fractions
+@item latin1jk
+@itemx latin2jk
+@itemx latin3jk
+Inputenc definition files that allow verbatim input in the respective ISO
+Latin codes.
+@item mathbol
+Blackboard bold fonts for use in maths.
+@item mathrsfs
+Mathematical script letters, as traditionally used in physics for Lagrangian,
+Hamiltonian, path integral measures, etc.
+@item parboxx
+New alignment options for parboxen at top and bottom of the box.
+@item sans
+Interchanges the roles of sans serif and roman fonts throughout the document.
+@item semtrans
+Support for special latin letters and diacritics used in transliteration of
+semitic languages
+@item smartmn
+Intelligent hyphen/minus, which guesses whether to render as hyphen or minus.
+@item sgmlcmpt
+Commands replacing the characters <, >, and &.
+@item tccompat
+A compatibility package for users of the older versions of the textcomp package.
+@item young
+Simple Young tableaux.
+@end table")
+ (license license:gpl2))) ;per the 00readme_txt file.
+
(define-public texlive-libertine
(package
(inherit (simple-texlive-package