summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:24:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:42 +0200
commit69f0c8cf5566848f0065f84d73c7d76e01475842 (patch)
treeffa6de054d32134f29e4ef7fa8a67d6f086ccbad /gnu/packages/tex.scm
parent11ecf9f48f53b3263240e714cf1de859a9db6149 (diff)
downloadguix-patches-69f0c8cf5566848f0065f84d73c7d76e01475842.tar
guix-patches-69f0c8cf5566848f0065f84d73c7d76e01475842.tar.gz
gnu: Add texlive-siunitx.
* gnu/packages/tex.scm (texlive-siunitx): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c5e36af064..2b15ffb0cd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7299,3 +7299,41 @@ The class may be used to simplify the preamble in sub-files. By default the
The behaviour in standalone mode may adjusted using a configuration file
@code{standalone.cfg} to redefine the standalone environment.")
(license license:lppl1.3+)))
+
+(define-public texlive-siunitx
+ (package
+ (name "texlive-siunitx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "/source/latex/siunitx/siunitx.dtx"
+ "/doc/latex/siunitx/README.md")
+ (base32
+ "0dmljnxgv2bwl3mi74iil41q03swvrm1b0ziwxlhc4m9lx31b1q1")))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/siunitx"
+ #:build-targets '("siunitx.dtx")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/siunitx") #t)))))
+ (propagated-inputs
+ `(("texlive-latex-l3kernel" ,texlive-latex-l3kernel)
+ ("texlive-latex-l3packages" ,texlive-latex-l3packages)))
+ (home-page "http://www.ctan.org/pkg/siunitx")
+ (synopsis "Comprehensive SI units package")
+ (description
+ "Typesetting values with units requires care to ensure that the combined
+mathematical meaning of the value plus unit combination is clear. In
+particular, the SI units system lays down a consistent set of units with rules
+on how they are to be used. However, different countries and publishers have
+differing conventions on the exact appearance of numbers (and units). A
+number of LaTeX packages have been developed to provide consistent application
+of the various rules. The @code{siunitx} package takes the best from the
+existing packages, and adds new features and a consistent interface. A number
+of new ideas have been incorporated, to fill gaps in the existing provision.
+The package also provides backward-compatibility with @code{SIunits},
+@code{sistyle}, @code{unitsdef} and @code{units}. The aim is to have one
+package to handle all of the possible unit-related needs of LaTeX users.")
+ (license license:lppl1.3c)))