summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-16 14:06:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:49 +0200
commit57bee3cc91419880e04798bef5079c151b4ac7e7 (patch)
tree7d7c9c2e57c2d80c6c1d695e1c574f3ec3cff7df /gnu/packages/tex.scm
parent1aaa117c0cbe0f7067ec3ad28b274260c0495c32 (diff)
downloadguix-patches-57bee3cc91419880e04798bef5079c151b4ac7e7.tar
guix-patches-57bee3cc91419880e04798bef5079c151b4ac7e7.tar.gz
gnu: Add texlive-palatino.
* gnu/packages/tex.scm (texlive-palatino): New variable. (texlive-fonts-adobe-palatino): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm174
1 files changed, 20 insertions, 154 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 79dcbd5ff2..1438e39121 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4898,161 +4898,24 @@ Adobe's basic set.")
(define-public texlive-fonts-adobe-times
(deprecated-package "texlive-fonts-adobe-times" texlive-times))
-(define-public texlive-fonts-adobe-palatino
+(define-public texlive-palatino
(package
- (name "texlive-fonts-adobe-palatino")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/type1/urw/palatino/"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "18dw5260c6fy7acxaqwrg3hw04kg63ijq4lkn56q5pa2g6nyylrp"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils)
- (ice-9 match))
- #:builder
- (begin
- (use-modules (guix build utils)
- (ice-9 match))
- (let ((root (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/"))
- (pkgs '(("source" . "fonts/type1/urw/palatino")
-
- ("palatino-afm" . "fonts/afm/adobe/palatino")
- ("palatino-tfm" . "fonts/tfm/adobe/palatino")
- ("palatino-vf" . "fonts/vf/adobe/palatino")
-
- ("urw-afm" . "fonts/afm/urw/palatino")
- ("urw35vf-tfm" . "fonts/tfm/urw35vf/palatino")
- ("urw35vf-vf" . "fonts/vf/urw35vf/palatino")
-
- ("palatino-tex" . "tex/latex/palatino")
- ("dvips" . "dvips/palatino")
- ("fonts-map" . "fonts/map/dvips/palatino"))))
- (for-each (match-lambda
- ((pkg . dir)
- (let ((target (string-append root dir)))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs pkg)
- target))))
- pkgs)
- #t))))
- (native-inputs
- `(("palatino-afm"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/afm/adobe/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-afm-" version "-checkout"))
- (sha256
- (base32
- "0pxizay730cx7rb9y5bqq9dn1zxx3arc33rmdsn7l29pc51flmmi"))))
- ("palatino-tfm"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/tfm/adobe/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-tfm-" version "-checkout"))
- (sha256
- (base32
- "1w1vm0sk9kpsy14yhyf1v1q3c6b97cgbba74g578bcwjlh810mg0"))))
- ("palatino-vf"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/vf/adobe/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-vf-" version "-checkout"))
- (sha256
- (base32
- "1maqfis8hpybcn9lmm8r2b1g56620lfpsncg0742c3kkjd6dh97h"))))
- ("urw-afm"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/afm/urw/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-urw-afm-" version "-checkout"))
- (sha256
- (base32
- "0gk0xwy1fs2si5kb1j3dzgm52c8sagv32gd9dmw88m7sgh5qkd87"))))
- ("urw35vf-tfm"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/tfm/urw35vf/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-urw35vf-tfm-" version "-checkout"))
- (sha256
- (base32
- "19aq3xwfg7vkf1qzjdxgcvcdqwpvpavq3l25y64xni72qx0kmppz"))))
- ("urw35vf-vf"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/vf/urw35vf/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-urw35vf-vf-" version "-checkout"))
- (sha256
- (base32
- "1lkn4p6zimrs0ah6mxsang4bicp8j7xzl016529a3f168an7mdmj"))))
- ("palatino-tex"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/palatino"))
- (revision %texlive-revision)))
- (file-name (string-append name "-tex-" version "-checkout"))
- (sha256
- (base32
- "0ng9w7i0p1nb51amla32jj86vx6p84m6qc7asam3g4x8w5jf7s27"))))
- ("dvips"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/dvips/palatino/"))
- (revision %texlive-revision)))
- (file-name (string-append name "-dvips-" version "-checkout"))
- (sha256
- (base32
- "1pdbkfmhx4kk3brh5lg6fyl9ad2kbjmkrhgcx84klnlhq01mfdhb"))))
- ("fonts-map"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/fonts/map/dvips/palatino/"))
- (revision %texlive-revision)))
- (file-name (string-append name "-fonts-map-" version "-checkout"))
- (sha256
- (base32
- "0rg13hyp652hp3gnrj5pbyb84zkqmyi1qnm8c6spcyaq8pm06l0d"))))))
+ (inherit (simple-texlive-package
+ "texlive-palatino"
+ (list "/dvips/palatino/"
+ "/fonts/afm/adobe/palatino/"
+ "/fonts/afm/urw/palatino/"
+ "/fonts/tfm/adobe/palatino/"
+ "/fonts/tfm/urw35vf/palatino/"
+ "/fonts/type1/urw/palatino/"
+ "/fonts/vf/adobe/palatino/"
+ "/fonts/vf/urw35vf/palatino/"
+
+ "/fonts/map/dvips/palatino/"
+ "/tex/latex/palatino/")
+ (base32
+ "12jc0av7v99857jigmva47qaxyllhpzsnqis10n0qya2kz44xf22")
+ #:trivial? #t))
(home-page "https://ctan.org/pkg/urw-base35")
(synopsis "URW Base 35 font pack for LaTeX")
(description
@@ -5061,6 +4924,9 @@ Adobe's basic set.")
;; No license version specified.
(license license:gpl3+)))
+(define-public texlive-fonts-adobe-palatino
+ (deprecated-package "texlive-fonts-adobe-palatino" texlive-palatino))
+
(define-public texlive-fonts-adobe-zapfding
(package
(name "texlive-fonts-adobe-zapfding")