summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-16 12:18:54 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-16 12:22:59 +0100
commit5674ea45a3faf87cc44eb7c63a97e7fc55fc0c3c (patch)
tree77a94c8eff1ddeffabb271c137cbc591966331d2 /gnu/packages/tex.scm
parentb85863f7ce99d05205e57358b36ff50656cca08b (diff)
downloadguix-patches-5674ea45a3faf87cc44eb7c63a97e7fc55fc0c3c.tar
guix-patches-5674ea45a3faf87cc44eb7c63a97e7fc55fc0c3c.tar.gz
gnu: Add texlive-todonotes.
* gnu/packages/tex.scm (texlive-todonotes): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 63b144c45b..35f2049dbf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7380,3 +7380,24 @@ subdivided bibliographies, such as bibliographies per chapter or
section.
@end enumerate\n")
(license license:lppl1.3c))))
+
+(define-public texlive-todonotes
+ (let ((template (simple-texlive-package
+ "texlive-todonotes"
+ (list "/doc/latex/todonotes/"
+ "/tex/latex/todonotes/")
+ (base32
+ "0lvxsskz4bdfxhd59hf77kiq8k4nh2spb66vc6hifdgi21z8r8wm")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (propagated-inputs
+ `(("texlive-latex-pgf" ,texlive-latex-pgf)
+ ("texlive-latex-xkeyval" ,texlive-latex-xkeyval)))
+ (home-page "http://www.ctan.org/pkg/todonotes")
+ (synopsis "Marking things to do in a LaTeX document")
+ (description "The @code{todonotes} package lets the user mark
+things to do later, in a simple and visually appealing way. The
+package takes several options to enable customization and finetuning
+of the visual appearance.")
+ (license license:lppl1.3+))))