summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-05 22:16:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-05 22:45:41 +0200
commit51bf1c518853badaebc48ac1144e5afd9b5862c2 (patch)
tree7e0e8f4fc9826b48aefa34ea4a8e03c9b975fe4c /gnu/packages/tex.scm
parenta72d343aea5827f4c8491751ea2767f067005395 (diff)
downloadguix-patches-51bf1c518853badaebc48ac1144e5afd9b5862c2.tar
guix-patches-51bf1c518853badaebc48ac1144e5afd9b5862c2.tar.gz
gnu: Add texlive-iftex.
* gnu/packages/tex.scm (texlive-iftex): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0fdd970dde..b792e72693 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7166,3 +7166,23 @@ or shading the cells of tables.")
a different path and manipulating characters. It includes the functionality
of the old package @code{pst-char}.")
(license license:lppl))))
+
+(define-public texlive-iftex
+ (let ((template (simple-texlive-package
+ "texlive-iftex"
+ (list "/doc/generic/iftex/"
+ "/tex/generic/iftex/iftex.sty")
+ (base32
+ "089zvw31gby150n1k0zdk2c0q97pgbqs46phxydaqil64b55nnl7")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/iftex")
+ (synopsis "Determine the currently used TeX engine")
+ (description "This package, which works both for Plain TeX and for
+LaTeX, defines the @code{\\ifPDFTeX}, @code{\\ifXeTeX}, and @code{\\ifLuaTeX}
+conditionals for testing which engine is being used for typesetting. The
+package also provides the @code{\\RequirePDFTeX}, @code{\\RequireXeTeX}, and
+@code{\\RequireLuaTeX} commands which throw an error if pdfTeX, XeTeX or
+LuaTeX (respectively) is not the engine in use.")
+ (license license:lppl1.3+))))