summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-21 12:44:23 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-21 12:47:24 +0100
commit475e3768fc466f5cd826c2c7964072e10d9c9af1 (patch)
tree0282e4a14f9eed48adfe56ad6a9a2f2a7429d014 /gnu/packages/tex.scm
parent90492a9f13b4b8eaa6025d5a18e0b130cf257dbe (diff)
downloadguix-patches-475e3768fc466f5cd826c2c7964072e10d9c9af1.tar
guix-patches-475e3768fc466f5cd826c2c7964072e10d9c9af1.tar.gz
gnu: Add texlive-caption.
* gnu/packages/tex.scm (texlive-caption): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f521c36b8e..8ecdbf140c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7444,3 +7444,27 @@ various fonts are provided. An alternative package
@code{letterspace}, which also works with plain TeX, is included in
the bundle.")
(license license:lppl1.3c))))
+
+(define-public texlive-caption
+ (let ((template (simple-texlive-package
+ "texlive-caption"
+ (list "/doc/latex/caption/"
+ "/tex/latex/caption/")
+ (base32
+ "09gmh8yjj9f5zak8r18g87w9p5jn7flnvmlhxmvdq6992mbdc6hg")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/caption")
+ (synopsis "Customising captions in floating environments")
+ (description "The @code{caption} package provides many ways to
+customise the captions in floating environments like figure and table.
+Facilities include rotating captions, sideways captions and continued
+captions (for tables or figures that come in several parts). A list
+of compatibility notes, for other packages, is provided in the
+documentation. The package also provides the \"caption outside
+float\" facility, in the same way that simpler packages like
+@code{capt-ofcapt-of} do. The package supersedes @code{caption2}.
+Packages @code{bicaption}, @code{ltcaption}, @code{newfloat},
+@code{subcaption} and @code{totalcount} are included in the bundle.")
+ (license license:lppl1.3+))))