summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 15:48:37 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 18:37:50 +0100
commit3f66b4c2664fef98bcd15a9a63f62fb45f2d9b18 (patch)
tree3541e31b873b66160b52f79b0ec4299a52fde49f /gnu/packages/tex.scm
parent85de88f1adcf5b91afe76bf671c05b8596821920 (diff)
downloadguix-patches-3f66b4c2664fef98bcd15a9a63f62fb45f2d9b18.tar
guix-patches-3f66b4c2664fef98bcd15a9a63f62fb45f2d9b18.tar.gz
gnu: lyx: Remove reference to '%outputs'.
* gnu/packages/tex.scm (lyx)[arguments]: Rewrite as gexps. Refer to #$output instead of '%outputs', which 'qt-build-system' no longer defines.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm53
1 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c6304aa99..910be212ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38,6 +38,7 @@
(define-module (gnu packages tex)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system copy)
@@ -7299,33 +7300,31 @@ and Karl Berry.")
#t))))
(build-system qt-build-system)
(arguments
- `(#:configure-flags `("-DLYX_USE_QT=QT5"
- "-DLYX_EXTERNAL_BOOST=1"
- "-DLYX_INSTALL=1"
- "-DLYX_RELEASE=1"
- "-DLYX_PROGRAM_SUFFIX=OFF"
- ,(string-append "-DLYX_INSTALL_PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-python
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("lib/configure.py"
- "src/support/ForkedCalls.cpp"
- "src/support/Systemcall.cpp"
- "src/support/os.cpp"
- "src/support/filetools.cpp")
- (("\"python ")
- (string-append "\""
- (assoc-ref inputs "python")
- "/bin/python3 ")))
- #t))
- (add-after 'unpack 'add-missing-test-file
- (lambda _
- ;; Create missing file that would cause tests to fail.
- (with-output-to-file "src/tests/check_layout.cmake"
- (const #t))
- #t)))))
+ (list #:configure-flags
+ #~(list "-DLYX_USE_QT=QT5"
+ "-DLYX_EXTERNAL_BOOST=1"
+ "-DLYX_INSTALL=1"
+ "-DLYX_RELEASE=1"
+ "-DLYX_PROGRAM_SUFFIX=OFF"
+ (string-append "-DLYX_INSTALL_PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-python
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("lib/configure.py"
+ "src/support/ForkedCalls.cpp"
+ "src/support/Systemcall.cpp"
+ "src/support/os.cpp"
+ "src/support/filetools.cpp")
+ (("\"python ")
+ (string-append "\""
+ (assoc-ref inputs "python")
+ "/bin/python3 ")))))
+ (add-after 'unpack 'add-missing-test-file
+ (lambda _
+ ;; Create missing file that would cause tests to fail.
+ (with-output-to-file "src/tests/check_layout.cmake"
+ (const #t)))))))
(inputs
`(("boost" ,boost)
("hunspell" ,hunspell) ; Note: Could also use aspell instead.