summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-08 11:53:10 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-08 12:14:37 +0200
commit3aafcdbd8ba2fdec961fd8e7d7c892e20caf4787 (patch)
tree446abd03f83f5b832990b94aec9748b00c813d59 /gnu/packages/tex.scm
parentd08921addeb4b432205af6260c9a2ebd7d611989 (diff)
downloadguix-patches-3aafcdbd8ba2fdec961fd8e7d7c892e20caf4787.tar
guix-patches-3aafcdbd8ba2fdec961fd8e7d7c892e20caf4787.tar.gz
gnu: texlive-amsmath: Supersed 'texlive-latex-amsmath'.
* gnu/packages/tex.scm (texlive-latex-amsmath): Redefine as a deprecated alias for 'texlive-amsmath'. (texlive-base): Use 'texlive-amsmath' instead of 'texlive-latex-amsmath'. * gnu/packages/python-xyz.scm (python-matplotlib-documentation)[native-inputs]: Use 'texlive-amsmath instead of 'texlive-latex-amsmath'. (python-nbconvert)[native-inputs]: Likewise. * gnu/packages/radio.scm (gnuradio)[native-inputs]: Likewise. (libosmo-dsp)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 3 insertions, 32 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f6716c38b8..76cc0f7119 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3768,37 +3768,6 @@ loading fonts by their proper names instead of file names.")
(define-deprecated-package texlive-luatex-luaotfload texlive-luaotfload)
-(define-public texlive-latex-amsmath
- (package
- (name "texlive-latex-amsmath")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "amsmath"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "172zybw7rp05jca8wl6x0mh6z6gncdyi1j9wdfyjnhbvqw0z4wi4"))))
- ;; This package misses important files
- (replacement texlive-amsmath)
- (build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/amsmath"))
- (home-page "https://www.ctan.org/pkg/amsmath")
- (synopsis "AMS mathematical facilities for LaTeX")
- (description
- "This is the principal package in the AMS-LaTeX distribution. It adapts
-for use in LaTeX most of the mathematical features found in AMS-TeX; it is
-highly recommended as an adjunct to serious mathematical typesetting in LaTeX.
-When amsmath is loaded, AMS-LaTeX packages @code{amsbsyamsbsy} (for bold
-symbols), @code{amsopnamsopn} (for operator names) and
-@code{amstextamstext} (for text embedded in mathematics) are also loaded.
-This package is part of the LaTeX required distribution; however, several
-contributed packages add still further to its appeal; examples are
-@code{empheqempheq}, which provides functions for decorating and highlighting
-mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
-definitions.")
- (license license:lppl1.3c+)))
-
(define-public texlive-amsmath
(let ((template (simple-texlive-package
"texlive-amsmath"
@@ -3844,6 +3813,8 @@ mathematics, and @code{ntheoremntheorem}, for specifying theorem (and similar)
definitions.")
(license license:lppl1.3c+))))
+(define-deprecated-package texlive-latex-amsmath texlive-amsmath)
+
(define-public texlive-amscls
(let ((template (simple-texlive-package
"texlive-amscls"
@@ -4241,7 +4212,7 @@ part of the LaTeX required set of packages.")
texlive-latex-base
texlive-kpathsea ;for mktex.opt
;; LaTeX packages from the "required" set.
- texlive-latex-amsmath
+ texlive-amsmath
texlive-amscls
texlive-babel
texlive-generic-babel-english