summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-18 15:07:27 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-09-18 15:10:13 +0100
commit389b71aa0f756608236565067f2f77ee1f9390da (patch)
tree14f93961a1db7b94a397be83ff117e6f027891dd /gnu/packages/tex.scm
parent62f9921c830129ff9f484472a078cf0a35e526dc (diff)
downloadguix-patches-389b71aa0f756608236565067f2f77ee1f9390da.tar
guix-patches-389b71aa0f756608236565067f2f77ee1f9390da.tar.gz
gnu: Add texlive-microtype.
* gnu/packages/tex.scm (texlive-microtype): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 78dd37733d..3ac6e5e63f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7419,3 +7419,27 @@ units in a standard-looking way. The package is based upon
@code{nicefrac}, a package for typing fractions. @code{nicefrac} is
included in the @code{units} bundle.")
(license license:gpl3+))))
+
+(define-public texlive-microtype
+ (let ((template (simple-texlive-package
+ "texlive-microtype"
+ (list "/doc/latex/microtype/"
+ "/tex/latex/microtype/")
+ (base32
+ "0xmjpzbj4nqmnl5m7xx1bshdk2c8n57rmbvn0j479ypj4wdlq9iy")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (home-page "http://www.ctan.org/pkg/microtype")
+ (synopsis "Subliminal refinements towards typographical perfection")
+ (description "@code{microtype} provides a LaTeX interface to the
+micro-typographic extensions that were introduced by pdfTeX and have
+since propagated to XeTeX and LuaTeX: most prominently character
+protrusion and font expansion, the adjustment of kerning and interword
+spacing, hyphenatable letterspacing and the possibility to disable all
+or selected ligatures. These features may be applied to customisable
+sets of fonts. All micro-typographic aspects of the fonts can be
+configured in a straight-forward and flexible way. Settings for
+various fonts are provided. An alternative package @code{letterspace},
+which also works with plain TeX, is included in the bundle.")
+ (license license:lppl1.3c))))