summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-07 18:48:21 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-04-07 18:51:02 +0100
commit2d77c270f4196cddd5739cda0156b610607a26a5 (patch)
treef75a4ec05478196f3fcd92ce3740bb7817ea3741 /gnu/packages/tex.scm
parent8a32b6a542e49ae989a4418c73546e558c547479 (diff)
downloadguix-patches-2d77c270f4196cddd5739cda0156b610607a26a5.tar
guix-patches-2d77c270f4196cddd5739cda0156b610607a26a5.tar.gz
gnu: Add texlive-fontaxes.
* gnu/packages/tex.scm: New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ec21221ea1..c8bac7eea7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7905,3 +7905,26 @@ matching maths fonts are provided by the @code{fourier} and
@code{mathdesign} font packages.")
(license (license:fsf-free
"http://mirrors.ctan.org/fonts/utopia/README"))))
+
+(define-public texlive-fontaxes
+ (package
+ (name "texlive-fontaxes")
+ (version "1.0e")
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "fontaxes"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "19mhp9l7cjw0sbq55c9lz0l2pffkyhyir3i63jqynifjmglbgkl7"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/fontaxes"))
+ (home-page "http://www.ctan.org/pkg/fontaxes")
+ (synopsis "Additional font axes for LaTeX")
+ (description "The @code{fontaxes} package adds several new font
+axes on top of LaTeX's New Font Selection Scheme (NFSS). In
+particular, it splits the shape axis into a primary and a secondary
+shape axis and it adds three new axes to deal with the different
+figure versions offered by many professional fonts.")
+ (license license:lppl1.3+)))