summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:53:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:43 +0200
commit1b1d8577892a92fc5098b6246e452ee07ee380f6 (patch)
treeb5726e623e07f56f004bce4127198007dd07a0f7 /gnu/packages/tex.scm
parentbeed8377595cda72d69786539f9670597d4b183c (diff)
downloadguix-patches-1b1d8577892a92fc5098b6246e452ee07ee380f6.tar
guix-patches-1b1d8577892a92fc5098b6246e452ee07ee380f6.tar.gz
gnu: Add texlive-hyphen-coptic.
* gnu/packages/tex.scm (texlive-hyphen-coptic): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b7ed687101..ed5ccfde23 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1542,6 +1542,20 @@ Chinese pinyin T1/EC and UTF-8 encodings.")
Slavonic in UTF-8 encoding.")
(license license:expat)))
+(define-public texlive-hyphen-coptic
+ (package
+ (inherit (texlive-hyphen-package
+ "texlive-hyphen-coptic" "cop"
+ (list "/tex/generic/hyph-utf8/patterns/tex-8bit/copthyph.tex"
+ "/tex/generic/hyph-utf8/patterns/tex/hyph-cop.tex")
+ (base32
+ "07i03jpdfy4ip7zbg4gnk4hk8zwj8rlni9dgrb1p8mfw2w19d80c")))
+ (synopsis "Hyphenation patterns for Coptic")
+ (description "The package provides hyphenation patterns for Coptic in
+UTF-8 encoding as well as in ASCII-based encoding for 8-bit engines.")
+ ;; No explicit license declaration, so we use the project license.
+ (license license:lppl)))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package