summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2022-07-16 15:42:01 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:27 +0200
commit1730148f7c6b1d79f0ce318b2bda5c707b06807d (patch)
treef4c9ffcae6423ec499476a55b4197143d5786536 /gnu/packages/tex.scm
parent79faefb8afdd0b6aab3e04fe64bba91abfcf333b (diff)
downloadguix-patches-1730148f7c6b1d79f0ce318b2bda5c707b06807d.tar
guix-patches-1730148f7c6b1d79f0ce318b2bda5c707b06807d.tar.gz
gnu: Add texlive-datetime2.
* gnu/packages/tex.scm (texlive-datetime2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5948ab3451..8578c8fe56 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11160,3 +11160,28 @@ environment of package @code{lscape}, by setting the PDF @code{/Rotate} page
attribute. Pages with this attribute will be displayed in landscape
orientation by conforming PDF viewers.")
(license license:lppl1.3+)))
+
+(define-public texlive-datetime2
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-datetime2"
+ (list "doc/latex/datetime2/"
+ "source/latex/datetime2/"
+ "tex/latex/datetime2/")
+ (base32 "0yjkpfic1ni4j2g61rrjj5hjyd43shc9c0sg1aivbbsmqh30dn33")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/datetime2")
+ (synopsis "Formats for dates, times and time zones")
+ (description
+ "The @code{datetime2} package provides commands for formatting dates, times
+and time zones and redefines @code{\\today} to use the same formatting style.
+In addition to @code{\\today}, you can also use
+@code{\\DTMcurrenttime} (current time) or @code{\\DTMnow} (current date and
+time). Dates and times can be saved for later use. The accompanying
+@code{datetime2-calc} package can be used to convert date-times to UTC+00:00.
+Language and regional support is provided by independently maintained and
+installed modules. The @code{datetime2-calc} package uses the
+@code{pgfcalendar} package (part of the PGF/TikZ bundle). This package
+replaces @code{datetime.sty} which is now obsolete.")
+ (license license:lppl1.3+)))