summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-01 12:13:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:24 -0400
commit13c19e3bfbf4b72aa149b034c9616eefcee1a53c (patch)
tree5b57955ce94e3d740cbe466c7635def48abeb686 /gnu/packages/tex.scm
parent5289d2851582c31b698b0a7faaa0d216db86b810 (diff)
downloadguix-patches-13c19e3bfbf4b72aa149b034c9616eefcee1a53c.tar
guix-patches-13c19e3bfbf4b72aa149b034c9616eefcee1a53c.tar.gz
gnu: Add texlive-zref.
* gnu/packages/tex.scm (texlive-zref): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82da10c41a..1ebaceb322 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6360,6 +6360,76 @@ Adobe's basic set.")
;; No license version specified.
(license license:gpl3+)))
+(define-public texlive-zref
+ (package
+ (inherit (simple-texlive-package
+ "texlive-zref"
+ (list "doc/latex/zref/"
+ "source/latex/zref/")
+ (base32 "09l2wrqx0navislkx15iazv7jy0ip8bqaw3c0hjf0jy81kqrrm01")))
+ (outputs '("out" "doc"))
+ (arguments
+ (list
+ #:build-targets #~(list "zref.dtx")
+ #:tex-directory "latex/zref"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (setenv "ROOT_DIR" (getcwd))
+ (chdir "source/latex/zref")))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (define doc (string-append (assoc-ref outputs "doc")
+ "/share/texmf-dist/doc"))
+ (mkdir-p doc)
+ (copy-recursively (string-append (getenv "ROOT_DIR") "/doc")
+ doc))))))
+ (propagated-inputs (list texlive-generic-atbegshi
+ texlive-generic-gettitlestring
+ texlive-generic-iftex
+ texlive-latex-atveryend
+ texlive-latex-kvoptions
+ texlive-latex-pdftexcmds
+ texlive-latex-xkeyval))
+ (home-page "https://github.com/ho-tex/zref")
+ (synopsis "Reference scheme for LaTeX")
+ (description "This package offers a means to remove the limitation, of
+only two properties, that is inherent in the way LaTeX's reference system
+works. The package implements an extensible referencing system, where
+properties may be defined and used in the course of a document. It provides
+an interface for macro programmers to access the new reference scheme and some
+modules that use it. Modules available are:
+@table @code
+@item zref-user
+use zref for traditional labels and references;
+@item zref-abspage
+retrieve absolute page numbers (physical pages, as opposed to the logical page
+number that is normally typeset when a page number is requested;
+@item zref-lastpage
+provide a zref-label for the last page of the document;
+@item zref-nextpage
+provide the page number of the next page of the document;
+@item zref-totpages
+provide the total number of pages in the document;
+@item zref-pagelayout
+provide the page layout parameters of a each page (which may then be printed
+at the end of the document);
+@item zref-perpage
+make a counter reset for each new page;
+@item zref-titleref
+make section title or caption text available through the reference system;
+@item zref-savepos
+make positions on a page available;
+@item zref-dotfill
+controlled dot-filling
+@item zref-env
+record the latest environment's name and the line it started on;
+@item zref-xr
+provide the facilities of the xr and xr-hyper packages.
+@end table")
+ (license license:lppl1.3c+)))
+
(define-deprecated-package texlive-fonts-adobe-zapfding texlive-zapfding)
(define-public texlive-fonts-rsfs