summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-02 16:08:57 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-02 19:26:16 +0100
commit107138164611a11972f261818373d1de95b3216d (patch)
tree9a630082fb7b2e12414a7bf40ddd3aeb92dcc1c5 /gnu/packages/tex.scm
parente5dbda5abc23c5ed716121872d1bbaa8bfcee79e (diff)
downloadguix-patches-107138164611a11972f261818373d1de95b3216d.tar
guix-patches-107138164611a11972f261818373d1de95b3216d.tar.gz
gnu: texlive-latex-listings: Rename to "texlive-listings".
Suggested by Ricardo Wurmus. * gnu/packages/tex.scm (texlive-latex-listings): Rename to... (texlive-listings): ... this. Adjust 'name' accordingly. (texlive-latex-listings): Define as deprecated. (texlive-latex-xkeyval)[propagated-inputs]: Add comment. * gnu/packages/docbook.scm (dblatex)[inputs]: Add comment.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 32707bba5c..758ec601b7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5836,14 +5836,16 @@ optional arguments, or for macros that are defined as robust macros by
that also takes care of the involved internal macros.")
(license license:lppl1.3c+)))
-(define-public texlive-latex-listings
+(define-public texlive-listings
(package
- (name "texlive-latex-listings")
+ (name "texlive-listings")
(version (number->string %texlive-revision))
(source (origin
(method svn-fetch)
(uri (texlive-ref "latex" "listings"))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name
+ ;; TODO: Drop "latex-" on next rebuild cycle.
+ (string-append "texlive-latex-listings-" version "-checkout"))
(sha256
(base32
"082zri3gp8s6p2difhk1pbix2vzmvsf6fmld2z78v35xwk3fiya0"))))
@@ -5860,6 +5862,8 @@ is needed. Keywords, comments and strings can be typeset using different
styles. Support for @code{hyperref} is provided.")
(license license:lppl1.3+)))
+(define-deprecated-package texlive-latex-listings texlive-listings)
+
(define-public texlive-latex-jknapltx
(package
(name "texlive-latex-jknapltx")
@@ -9035,7 +9039,10 @@ are part of the LaTeX required tools distribution, comprising the packages:
texlive-graphics-def
texlive-xcolor
texlive-latex-footmisc
+
+ ;; TODO: Use non-deprecated name on next rebuild cycle.
texlive-latex-listings
+
texlive-generic-iftex
texlive-pstricks
texlive-pst-text