summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-10 21:42:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-11 09:56:30 +0300
commit03a7b67b314286a9185535f5ecbb7cde97ae2c97 (patch)
treeba436a7f5df1d49c5243e22195350f309f072b1f /gnu/packages/tex.scm
parent7a7a29445ced24af0dcdabfe8011538711fe05d9 (diff)
downloadguix-patches-03a7b67b314286a9185535f5ecbb7cde97ae2c97.tar
guix-patches-03a7b67b314286a9185535f5ecbb7cde97ae2c97.tar.gz
gnu: lyx: Update to 2.3.5.1.
* gnu/packages/tex.scm (lyx): Update to 2.3.5.1. [arguments]: Remove 'fix-compilation-with-boost-1.69 phase. In 'patch-python phase patch more files, substitute with python3. Split 'setenv-check and create empty file after 'unpack.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 16c80324fd..cd8270634c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6116,15 +6116,15 @@ and Karl Berry.")
(define-public lyx
(package
(name "lyx")
- (version "2.3.3")
+ (version "2.3.5.1")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.lyx.org/pub/lyx/stable/"
(version-major+minor version) ".x/"
- "lyx-" version ".tar.gz"))
+ "lyx-" version ".tar.xz"))
(sha256
(base32
- "0j3xincwmsscfgv13g3z6h4kx1qfzgg8x71fs393akcdxsh2g07c"))
+ "0mv32s26igm0pd8vs7d2mk1240dpr83y0a2wyh3xz6b67ph0w157"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -6147,19 +6147,17 @@ and Karl Berry.")
(guix build qt-utils))
#:phases
(modify-phases %standard-phases
- ;; See ;; https://www.lyx.org/trac/changeset/3a123b90af838b08680471d87170c38e56787df9/lyxgit
- (add-after 'unpack 'fix-compilation-with-boost-1.69
- (lambda _
- (substitute* "src/support/FileName.cpp"
- (("^template struct boost::detail::crc_table_t.*") ""))
- #t))
(add-after 'unpack 'patch-python
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("src/support/os.cpp")
+ (substitute* '("lib/configure.py"
+ "src/support/ForkedCalls.cpp"
+ "src/support/Systemcall.cpp"
+ "src/support/os.cpp"
+ "src/support/filetools.cpp")
(("\"python ")
(string-append "\""
(assoc-ref inputs "python")
- "/bin/python ")))
+ "/bin/python3 ")))
#t))
(add-after 'patch-python 'patch-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
@@ -6169,13 +6167,14 @@ and Karl Berry.")
(assoc-ref outputs "out")
"/")))
#t))
- (add-before 'check 'setenv-check
+ (add-after 'unpack 'add-missing-test-file
(lambda _
;; Create missing file that would cause tests to fail.
- (with-output-to-file (string-append "../lyx-"
- ,version
- "/src/tests/check_layout.cmake")
+ (with-output-to-file "src/tests/check_layout.cmake"
(const #t))
+ #t))
+ (add-before 'check 'setenv-check
+ (lambda _
(setenv (string-append "LYX_DIR_"
(string-join
(string-split