summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-25 20:48:43 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-07-29 16:17:22 +0200
commitcb3625bcd77fe84e24ad5ad99dab7a7134227add (patch)
treeccd47574733f4cbcf4ce89548689d0ee34153d87 /gnu/packages/terminals.scm
parentf81573500edd777dc3d6a35aef8b874297e19670 (diff)
downloadguix-patches-cb3625bcd77fe84e24ad5ad99dab7a7134227add.tar
guix-patches-cb3625bcd77fe84e24ad5ad99dab7a7134227add.tar.gz
gnu: Add go-github-com-junegunn-fzf.
* gnu/packages/terminals.scm (go-github-com-junegunn-fzf): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 4d0e875012..df8d1e4b79 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libevent)
@@ -754,6 +755,35 @@ with terminals in Go.")
(home-page "https://go.googlesource.com/crypto/")
(license license:bsd-3))))
+(define-public go-github-com-junegunn-fzf
+ (package
+ (name "go-github-com-junegunn-fzf")
+ (version "0.18.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/junegunn/fzf")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pwpr4fpw56yzzkcabzzgbgwraaxmp7xzzmap7w1xsrkbj7dl2xl"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/junegunn/fzf"))
+ (inputs
+ `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+ ("go-github-com-mattn-go-shellwords" ,go-github-com-mattn-go-shellwords)
+ ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-github-com-gdamore-tcell" ,go-github-com-gdamore-tcell)
+ ("go-golang-org-x-crypto-ssh-terminal" ,go-golang-org-x-crypto-ssh-terminal)))
+ (home-page "https://github.com/junegunn/fzf")
+ (synopsis "Command-line fuzzy-finder")
+ (description "This package provides an interactive command-line filter
+usable with any list--including files, command history, processes and more.")
+ (license license:expat)))
+
(define-public go-github.com-howeyc-gopass
(let ((commit "bf9dde6d0d2c004a008c27aaee91170c786f6db8")
(revision "0"))