summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-29 10:05:00 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-29 10:10:06 +0100
commitb412ddcb1a73bb8d7c9941ac3018e26345d70218 (patch)
tree6c93c2d58b25b17b55edd5ee03f14e15cbbe605f /gnu/packages/terminals.scm
parent23c2598233a21699d4b2c6e595d9491a4c981e72 (diff)
downloadguix-patches-b412ddcb1a73bb8d7c9941ac3018e26345d70218.tar
guix-patches-b412ddcb1a73bb8d7c9941ac3018e26345d70218.tar.gz
gnu: kitty: Update to 0.13.3.
* gnu/packages/terminals.scm (kitty): Update to 0.13.3. [inputs]: Replace python2-pygments with python-pygments. Add wayland. [arguments]: Add 'hard-code-libegl phase.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 236923a2d6..7f52c6efd4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
+;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -910,7 +911,7 @@ tmux.")
(define-public kitty
(package
(name "kitty")
- (version "0.13.1")
+ (version "0.13.3")
(home-page "https://sw.kovidgoyal.net/kitty/")
(source
(origin
@@ -921,7 +922,7 @@ tmux.")
(file-name (git-file-name name version))
(sha256
(base32
- "1j24zjasdh48z7majfpqr71n1wn5a9688wsmmqn26v8kfb68pqs4"))
+ "1y0vd75j8g61jdj8miml79w5ri3pqli5rv9iq6zdrxvzfa4b2rmb"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -943,7 +944,8 @@ tmux.")
("libpng" ,libpng)
("freetype" ,freetype)
("fontconfig" ,fontconfig)
- ("pygments" ,python2-pygments)))
+ ("pygments" ,python-pygments)
+ ("wayland" ,wayland)))
(native-inputs
`(("pkg-config" ,pkg-config)
("libxrandr" ,libxrandr)
@@ -959,6 +961,15 @@ tmux.")
(arguments
'(#:phases (modify-phases %standard-phases
(delete 'configure)
+ ;; Wayland backend requires EGL, which isn't found
+ ;; out-of-the-box for some reason. Hard-code it instead.
+ (add-after 'unpack 'hard-code-libegl
+ (lambda _
+ (let* ((mesa (assoc-ref %build-inputs "libgl1-mesa"))
+ (libegl (string-append mesa "/lib/libEGL.so.1")))
+ (substitute* "glfw/egl_context.c"
+ (("libEGL.so.1") libegl)))
+ #t))
(replace 'build
(lambda _
(invoke "python3" "setup.py" "linux-package")))