summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorJosé Miguel Sánchez García <jmi2k@openmailbox.org>2017-01-05 00:23:18 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-01-05 13:09:19 +0100
commitabe2ec735fd8c13985901377ba358e51c57e817c (patch)
treea5576d3373622dc8530a07b8fed5e0665cd3882b /gnu/packages/terminals.scm
parent88a46c9812e4ac2e14f79089e63376936b6988f5 (diff)
downloadguix-patches-abe2ec735fd8c13985901377ba358e51c57e817c.tar
guix-patches-abe2ec735fd8c13985901377ba358e51c57e817c.tar.gz
gnu: Add beep.
* gnu/packages/terminals.scm (beep): New variable. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 52767ba6cb..0b671d0ba9 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -4,7 +4,8 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -326,3 +327,37 @@ configuration, testing, and debugging tool. It has also serves well
as a low-tech serial communications program to allow access to all
types of devices that provide serial consoles.")
(license license:gpl2+)))
+
+(define-public beep
+ (package
+ (name "beep")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.johnath.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bgch6jq5cahakk3kbr9549iysf2dik09afixxy5brbxk1xfzb2r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile" (("/usr") (assoc-ref outputs "out")))))
+ (add-before 'install 'create-output-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref %outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man/man1"))))))))
+ (synopsis "Linux command-line utility to control the PC speaker")
+ (description "beep allows the user to control the PC speaker with precision,
+allowing different sounds to indicate different events. While it can be run
+quite happily on the command line, its intended place of residence is within
+scripts, notifying the user when something interesting occurs. Of course, it
+has no notion of what's interesing, but it's very good at that notifying part.")
+ (home-page "http://www.johnath.com/beep")
+ (license license:gpl2+)))