summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/terminals.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm38
1 files changed, 36 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 79d7af42ad..292c101407 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -102,6 +102,40 @@
#:use-module (gnu packages xorg)
#:use-module (srfi srfi-26))
+(define-public libptytty
+ (package
+ (name "libptytty")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yusiwen/libptytty")
+ (commit "b9694ea18e0dbd78213f55233a430325c13ad63e")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g8by1m6ya4r47p137mw4ddml40js0zh6mdb9n6ib49ayngv8ak3"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (home-page "https://github.com/yusiwen/libptytty")
+ (synopsis
+ "Portable, secure PTY/TTY and @file{utmp}/@file{wtmp}/@file{lastlog} handling")
+ (description
+ "Libptytty is a small C/C++ library to manage pseudo-ttys in a uniform way,
+created out of frustration over the many differences of PTY/TTY handling in
+different operating systems.
+
+In addition to mere PTY/TTY management, it supports updating the session
+database at @file{utmp}, and @file{wtmp}/@file{lastlog} for login shells.
+
+It also supports @code{fork}ing after start-up and dropping privileges in the
+calling process. This reduces the potential attack surface: if the calling
+process were to be compromised by the user starting the program, there would be
+less to gain, as only the helper process is running with privileges (e.g.,
+@code{setuid}/@code{setgid}).")
+ (license license:gpl2+)))
+
(define-public tilda
(package
(name "tilda")
@@ -834,7 +868,7 @@ a server/client mode.")
(define-public sakura
(package
(name "sakura")
- (version "3.8.3")
+ (version "3.8.4")
(source (origin
(method url-fetch)
(uri (string-append "https://launchpad.net/sakura/trunk/"
@@ -842,7 +876,7 @@ a server/client mode.")
".tar.bz2"))
(sha256
(base32
- "1r2kpvxx21r407s07m5p5x0dam6x863991nmcv6k5ap873fxqh2h"))))
+ "1d8n32xnj21q2xx13xs2r9cfjaq31mxiyhx6d57x9cwnhwb11xn3"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no check phase