summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorphodina via Guix-patches via <guix-patches@gnu.org>2021-11-10 13:41:57 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-15 11:26:17 +0100
commit879bcb71e82b1a463e130b3acdd1552b1fcd890b (patch)
treeb4ab164eccf8a74f53fc8464d1b2ebe3746714f8 /gnu/packages/terminals.scm
parent50f3b082a728fdda78c78753e5c4fd15e7f483b2 (diff)
downloadguix-patches-879bcb71e82b1a463e130b3acdd1552b1fcd890b.tar
guix-patches-879bcb71e82b1a463e130b3acdd1552b1fcd890b.tar.gz
gnu: Add mtm.
* gnu/packages/terminals.scm (mtm): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index daecc95837..0410b1e960 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -23,11 +23,13 @@
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright @ 2020 luhux <luhux@outlook.com>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -424,6 +426,64 @@ character sets and encodings from around the world. It can display double-width
Vietnamese, and bi-directional scripts like Arabic and Hebrew.")
(license license:bsd-3)))
+(define-public mtm
+ (package
+ (name "mtm")
+ (version "1.2.1")
+ (source
+ (origin
+ (uri (git-reference
+ (url "https://github.com/deadpixi/mtm")
+ (commit version)))
+ (method git-fetch)
+ (sha256
+ (base32 "0gibrvah059z37jvn1qs4b6kvd4ivk2mfihmcpgx1vz6yg70zghv"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-before 'build 'fix-headers
+ (lambda _
+ (substitute* "config.def.h"
+ (("ncursesw/curses.h") "curses.h"))))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ ;; install binary
+ (mkdir-p (string-append out "bin/"))
+ (install-file "mtm" (string-append out "/bin"))
+ ;; install manpage
+ (mkdir-p (string-append out "share/man/man1"))
+ (install-file "mtm.1" (string-append out "/share/man/man1"))
+ ;; install terminfo
+ (mkdir-p (string-append out "share/terminfo"))
+ (invoke (string-append (assoc-ref inputs "ncurses") "/bin/tic")
+ "-x" "-s" "-o"
+ (string-append
+ out "/share/terminfo")
+ "mtm.ti")))))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ ;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
+ ;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TERMINFO_DIRS")
+ (files '("share/terminfo")))))
+ (home-page "https://github.com/deadpixi/mtm")
+ (synopsis "Micro Terminal Multiplexer")
+ (description
+ "This package provides multiplexer for the terminal focused on simplicity,
+compatibility, size and stability.")
+ (license (list license:gpl3+
+ license:bsd-3)))) ;vtparser.c
+
(define-public picocom
(package
(name "picocom")