summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-02-16 22:48:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-16 22:58:10 +0100
commit61a73c533cf7c5f729da118a6a201107f34fa220 (patch)
treed952660b66c874341cc7344a6ca3549fada7bbfd /gnu/packages/terminals.scm
parentb819512ca2cce1051c5fea26328da2e5d6a9a101 (diff)
downloadguix-patches-61a73c533cf7c5f729da118a6a201107f34fa220.tar
guix-patches-61a73c533cf7c5f729da118a6a201107f34fa220.tar.gz
gnu: alacritty: Add comment.
* gnu/packages/terminals.scm (alacritty)[arguments]: Try to explain why this field is so ugly, and what might be done to avoid it.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 831e10a8e3..291a241473 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1276,6 +1276,12 @@ made by suckless.")
(libxkbcommon (assoc-ref inputs "libxkbcommon"))
(libwayland (assoc-ref inputs "wayland"))
(mesa (assoc-ref inputs "mesa")))
+ ;; Fix dlopen()ing some libraries on pure Wayland (no $DISPLAY):
+ ;; Failed to initialize any backend! Wayland status: NoWaylandLib
+ ;; XXX We patch transitive dependencies that aren't even direct
+ ;; inputs to this package, because of the way Guix's Rust build
+ ;; system currently works. <http://issues.guix.gnu.org/46399>
+ ;; might fix this and allow patching them directly.
(substitute* (string-append vendor-dir "/"
smithay-client-toolkit-src
"/seat/keyboard/ffi.rs")
@@ -1297,6 +1303,8 @@ made by suckless.")
"/client.rs")
(("libwayland-client\\.so")
(string-append libwayland "/lib/libwayland-client.so")))
+
+ ;; Mesa is needed everywhere.
(substitute*
(string-append vendor-dir "/" glutin-api "glx/mod.rs")
(("libGL.so") (string-append mesa "/lib/libGL.so")))