summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-31 14:59:36 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-02-15 21:44:06 +0100
commit573450e60cc7c8f5475c2c1432c0a0ee11737ebc (patch)
tree5bd96819885188c25cbdf296fa429f144db9527b /gnu/packages/terminals.scm
parent46ddcf4a291cc7e922276f120f40f63b3be1fdfa (diff)
downloadguix-patches-573450e60cc7c8f5475c2c1432c0a0ee11737ebc.tar
guix-patches-573450e60cc7c8f5475c2c1432c0a0ee11737ebc.tar.gz
gnu: Add python-blessings.
* gnu/packages/terminals.scm (python-blessings, python2-blessings): New variables.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 229db1b62a..3c74f9807d 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -710,3 +710,34 @@ of VT100 terminal.")
(define-public python2-pyte
(package-with-python2 python-pyte))
+
+(define-public python-blessings
+ (package
+ (name "python-blessings")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "blessings" version))
+ (sha256
+ (base32
+ "1smngy65p8mi62lgm04icasx22v976szhs2aq95y2ljmi1srb4bl"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: For py3, 2to2 is used to convert the code, but test-suite fails
+ `(#:tests? #f))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/erikrose/blessings")
+ (synopsis "Python module to manage terminal color, styling, and
+positioning")
+ (description "Blessings is a pythonic API to manipulate terminal color,
+styling, and positioning. It provides similar features to curses but avoids
+some of curses’s limitations: it does not require clearing the whole screen
+for little changes, provides a scroll-back buffer after the program exits, and
+avoids styling altogether when the output is redirected to something other
+than a terminal.")
+ (license license:expat)))
+
+(define-public python2-blessings
+ (package-with-python2 python-blessings))