summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-13 22:35:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-13 22:35:05 +0100
commit424b1ae76901c538457bd3c30d9d9cf67e79855f (patch)
treeacc35c1160625618cd6083e728c6a4ff7e9cccc9 /gnu/packages/terminals.scm
parenta50e03014177d2f00b5b85d3e1c295406f842016 (diff)
parenteae2dbd47ac1f4a201b8584e2f88c30cd28e093a (diff)
downloadguix-patches-424b1ae76901c538457bd3c30d9d9cf67e79855f.tar
guix-patches-424b1ae76901c538457bd3c30d9d9cf67e79855f.tar.gz
Merge branch 'master' into python-tests
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm68
1 files changed, 68 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 8e648c4031..d0d99932c4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -365,3 +366,70 @@ scripts, notifying the user when something interesting occurs. Of course, it
has no notion of what's interesing, but it's very good at that notifying part.")
(home-page "http://www.johnath.com/beep")
(license license:gpl2+)))
+
+(define-public unibilium
+ (package
+ (name "unibilium")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mauke/unibilium/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1n7a0jrlwhn9nnkna76sbnjrr808m0pmzbiwznmp7rhmjl4z2fk2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:test-target "test"
+ ;; FIXME: tests require "prove"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("libtool" ,libtool)))
+ (home-page "https://github.com/mauke/unibilium")
+ (synopsis "Terminfo parsing library")
+ (description "Unibilium is a basic C terminfo library. It doesn't depend
+on curses or any other library. It also doesn't use global variables, so it
+should be thread-safe.")
+ (license license:lgpl3+)))
+
+(define-public libvterm
+ (package
+ (name "libvterm")
+ (version "0+bzr681")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.leonerd.org.uk/code/libvterm/"
+ "libvterm-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s56c8p1qz6frkcri0hg4qyydv2wcccj6n2xmz1dwcdqn38ldsmb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("libtool" ,libtool)
+ ("perl" ,perl)))
+ (home-page "http://www.leonerd.org.uk/code/libvterm/")
+ (synopsis "VT220/xterm/ECMA-48 terminal emulator library")
+ (description "Libvterm is an abstract C99 library which implements a VT220
+or xterm-like terminal emulator. It doesn't use any particular graphics
+toolkit or output system, instead it invokes callback function pointers that
+its embedding program should provide it to draw on its behalf. It avoids
+calling @code{malloc} during normal running state, allowing it to be used in
+embedded kernel situations.")
+ (license license:expat)))