summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/terminals.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm63
1 files changed, 60 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 971b506237..79d7af42ad 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -23,11 +23,13 @@
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright @ 2020 luhux <luhux@outlook.com>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -423,6 +425,64 @@ character sets and encodings from around the world. It can display double-width
Vietnamese, and bi-directional scripts like Arabic and Hebrew.")
(license license:bsd-3)))
+(define-public mtm
+ (package
+ (name "mtm")
+ (version "1.2.1")
+ (source
+ (origin
+ (uri (git-reference
+ (url "https://github.com/deadpixi/mtm")
+ (commit version)))
+ (method git-fetch)
+ (sha256
+ (base32 "0gibrvah059z37jvn1qs4b6kvd4ivk2mfihmcpgx1vz6yg70zghv"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-before 'build 'fix-headers
+ (lambda _
+ (substitute* "config.def.h"
+ (("ncursesw/curses.h") "curses.h"))))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ ;; install binary
+ (mkdir-p (string-append out "bin/"))
+ (install-file "mtm" (string-append out "/bin"))
+ ;; install manpage
+ (mkdir-p (string-append out "share/man/man1"))
+ (install-file "mtm.1" (string-append out "/share/man/man1"))
+ ;; install terminfo
+ (mkdir-p (string-append out "share/terminfo"))
+ (invoke (string-append (assoc-ref inputs "ncurses") "/bin/tic")
+ "-x" "-s" "-o"
+ (string-append
+ out "/share/terminfo")
+ "mtm.ti")))))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ ;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
+ ;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TERMINFO_DIRS")
+ (files '("share/terminfo")))))
+ (home-page "https://github.com/deadpixi/mtm")
+ (synopsis "Micro Terminal Multiplexer")
+ (description
+ "This package provides multiplexer for the terminal focused on simplicity,
+compatibility, size and stability.")
+ (license (list license:gpl3+
+ license:bsd-3)))) ;vtparser.c
+
(define-public picocom
(package
(name "picocom")
@@ -1223,9 +1283,6 @@ while also supporting native scrolling and @command{tmux} control mode
(@code{tmux -CC}).")
(license license:asl2.0)))
-(define-public et
- (deprecated-package "et" eternalterminal))
-
(define-public wterm
(package
(name "wterm")