summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-15 11:26:44 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-15 12:24:14 +0200
commit24356427af0844dafd596b300ca80d1d2aa0d93d (patch)
tree997e35c91efdc0a2cef39920ec8586ad88924483 /gnu/packages/terminals.scm
parent33dbb0465e8ac6b53fac0bc70a40d239648022eb (diff)
downloadguix-patches-24356427af0844dafd596b300ca80d1d2aa0d93d.tar
guix-patches-24356427af0844dafd596b300ca80d1d2aa0d93d.tar.gz
gnu: kmscon: Remove dependency on MESA.
* gnu/packages/terminals.scm (kmscon)[inputs]: Remove MESA. [arguments]: Add #:disallowed-references.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 103ec128d8..ece01b5b02 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -252,7 +252,10 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
(modules '((guix build utils)))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
+ `(;; The closure of MESA is huge so we'd rather avoid it.
+ #:disallowed-references (,mesa)
+
+ #:phases (modify-phases %standard-phases
(replace 'bootstrap
(lambda _
(setenv "NOCONFIGURE" "indeed")
@@ -285,7 +288,10 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
("libtsm" ,libtsm)
("libxkbcommon" ,libxkbcommon)
("logind" ,elogind)
- ("mesa" ,mesa)
+ ;; MESA can be used for accelerated video output via OpenGLESv2, but
+ ;; it's a bit dependency that we'd rather avoid in the installation
+ ;; image.
+ ;; ("mesa" ,mesa)
("pango" ,pango)
("udev" ,eudev)))
(synopsis "Linux KMS-based terminal emulator")