summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorJovany Leandro G.C <bit4bit@riseup.net>2019-09-01 05:52:09 -0500
committerLudovic Courtès <ludo@gnu.org>2019-09-04 13:02:27 +0200
commitf1371daa97a521d0e995599cf94fa2516c6784c9 (patch)
tree8fe629f3a0d025ccf2f28e51eaa63b4170091356 /gnu/packages/telephony.scm
parent191668bc9759dc87a27b5f4d55d214cc655f197f (diff)
downloadguix-patches-f1371daa97a521d0e995599cf94fa2516c6784c9.tar
guix-patches-f1371daa97a521d0e995599cf94fa2516c6784c9.tar.gz
gnu: twinkle: update to 1.10.2.
* gnu/packages/telephony.scm (twinkle): update to 1.10.2 * gnu/packages/patches/twinkle-include-qregexpvalidator.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove patch. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm80
1 files changed, 38 insertions, 42 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index cf37756503..41896f2eb6 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -491,28 +491,24 @@ Mumble consists of two applications for separate usage:
license:bsd-2))))
(define-public twinkle
- (let ((commit "02e1d1538af3337134bd7381dcd95f8d7775b30f")
- (revision "1"))
(package
- (name "twinkle")
- (version (git-version "1.10.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/LubosD/twinkle")
- (commit commit)))
- (patches
- (search-patches "twinkle-include-qregexpvalidator.patch"))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ds4rp4vr1wagn4m4m7ldqbsx5vgmgbfcqqgyhn1wf6s1dm0020z"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no test target
- #:configure-flags '("-DWITH_SPEEX=On")
- #:phases
- (modify-phases %standard-phases
+ (name "twinkle")
+ (version "1.10.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LubosD/twinkle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:configure-flags '("-DWITH_SPEEX=On")
+ #:phases
+ (modify-phases %standard-phases
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -528,30 +524,30 @@ Mumble consists of two applications for separate usage:
"/lib/qt5/qml"))
'("qtdeclarative" "qtquickcontrols"))))
#t))))))
- (native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("readline" ,readline)
- ("file" ,file)
- ("ucommon" ,ucommon)
- ("ccrtp" ,ccrtp)
- ("libxml2" ,libxml2)
- ("speex" ,speex)
- ("speexdsp" ,speexdsp)
- ("libsndfile" ,libsndfile)
- ("alsa-lib" ,alsa-lib)
- ("qttools" ,qttools)))
- (inputs
- `(("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("qtquickcontrols" ,qtquickcontrols)))
- (home-page "http://twinkle.dolezel.info/")
- (synopsis "Softphone for voice over IP and instant messaging")
- (description "Twinkle is a softphone for your voice over IP and instant
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("readline" ,readline)
+ ("file" ,file)
+ ("ucommon" ,ucommon)
+ ("ccrtp" ,ccrtp)
+ ("libxml2" ,libxml2)
+ ("speex" ,speex)
+ ("speexdsp" ,speexdsp)
+ ("libsndfile" ,libsndfile)
+ ("alsa-lib" ,alsa-lib)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols" ,qtquickcontrols)))
+ (home-page "http://twinkle.dolezel.info/")
+ (synopsis "Softphone for voice over IP and instant messaging")
+ (description "Twinkle is a softphone for your voice over IP and instant
messaging communcations using the SIP protocol. You can use it for direct IP
phone to IP phone communication or in a network using a SIP proxy to route your
calls and messages")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public pjproject
(package