summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
commit8ed9be3faccb865204de46d2a8ed3e96e59281b6 (patch)
tree77ba4c90cda569048bc9ce2e414ede1567130c88 /gnu/packages/telephony.scm
parent36930b2463fc933e7c5580f49413dbd14cf1df48 (diff)
parent715110a8a2e9e4b1a89635950744eb5260b8ee7f (diff)
downloadguix-patches-8ed9be3faccb865204de46d2a8ed3e96e59281b6.tar
guix-patches-8ed9be3faccb865204de46d2a8ed3e96e59281b6.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 8a84cbc2cd..9f38b53883 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -245,7 +245,7 @@ internet.")
(define-public libsrtp
(package
(name "libsrtp")
- (version "2.2.0")
+ (version "2.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -254,13 +254,25 @@ internet.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ac7xs1djb03j131f1gmqyfmrplblid9qqyxahs0shdy707r5ll6"))))
+ "1f7i3jdh1wzdv7zjlz7gs3xw5jqig9zw8z9awsqqcp54f94xdpvd"))))
(native-inputs
`(("psmisc" ,psmisc) ;some tests require 'killall'
("procps" ,procps)))
(build-system gnu-build-system)
(arguments
- '(#:test-target "runtest"))
+ '(#:test-target "runtest"
+ #:phases (modify-phases %standard-phases
+ (add-after 'build 'build-shared
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ ;; Build the shared library separately because
+ ;; the test runner requires a static build.
+ (apply invoke "make" "shared_library" make-flags)
+ #t))
+ (add-after 'install 'remove-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libsrtp2.a"))
+ #t)))))
(synopsis "Secure RTP (SRTP) Reference Implementation")
(description
"This package provides an implementation of the Secure Real-time Transport