summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-06-25 15:46:18 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-28 23:26:54 +0200
commit22ec89974b82cdfdb8fa619ebf7447cf04103807 (patch)
tree58a4ada364a8497ba1eb9824345c5fa46c7c9311 /gnu/packages/telephony.scm
parentead5c46147ebf352ad4804d52a766dcf105eda4f (diff)
downloadguix-patches-22ec89974b82cdfdb8fa619ebf7447cf04103807.tar
guix-patches-22ec89974b82cdfdb8fa619ebf7447cf04103807.tar.gz
gnu: mumble: Fix mumble-overlay.
The canonical mumble-overlay script searches for libmumble.so.1 in various directories, none of which are relevant in Guix installations and additionally does some work to match the architecture of the library to that of the command that will be executed. This work is unnecessary in Guix and only causes the script to fail, so we instead just hardcode the path. * gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4c84ddc85a..542d36a841 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -588,6 +588,16 @@ address of one of the participants.")
(substitute* "src/mumble/Settings.cpp"
(("bUsage = true;") "bUsage = false;"))
#t))
+ (add-before 'configure 'fix-mumble-overlay
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "scripts/mumble-overlay"
+ (lambda ()
+ (format #t "#!~a~%" (which "bash"))
+ (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
+ (string-append (assoc-ref outputs "out")
+ "/lib/mumble/libmumble.so.1"))
+ (format #t "exec \"${@}\"")))
+ #t))
(add-before 'install 'disable-murmur-ice
(lambda _
(substitute* "scripts/murmur.ini.system"