summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-22 14:27:24 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-22 14:27:46 +0200
commitcb150ca34f5daee327867c6a647d075c8a598c37 (patch)
tree9775a5066d8bc270426627184d7f95b1793895ae /gnu/packages/tcl.scm
parent886cf584db46eda53b86053cf944649ff2ad23de (diff)
downloadguix-patches-cb150ca34f5daee327867c6a647d075c8a598c37.tar
guix-patches-cb150ca34f5daee327867c6a647d075c8a598c37.tar.gz
gnu: perl-tk: Build sequentially.
Fixes <http://bugs.gnu.org/18262>. * gnu/packages/tcl.scm (perl-tk)[arguments]: Add #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index d7ac10cb16..099bad25f9 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -161,8 +161,8 @@ X11 GUIs.")
(home-page "http://www.tcl.tk/")
(synopsis "Graphical user interface toolkit for Tcl")
(description
- "Tk is a graphical toolkit for building graphical user interfaces
-(GUIs) in the Tcl language.")
+ "Tk is a graphical toolkit for building graphical user
+interfaces (GUIs) in the Tcl language.")
(license (package-license tcl))))
(define-public perl-tk
@@ -185,7 +185,10 @@ X11 GUIs.")
("libjpeg" ,libjpeg)))
(arguments
`(#:make-maker-flags `(,(string-append
- "X11=" (assoc-ref %build-inputs "libx11")))))
+ "X11=" (assoc-ref %build-inputs "libx11")))
+
+ ;; Fails to build in parallel: <http://bugs.gnu.org/18262>.
+ #:parallel-build? #f))
(synopsis "Graphical user interface toolkit for Perl")
(description
"Tk is a Graphical User Interface ToolKit.")