summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-06-22 17:11:06 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-06-22 17:11:27 +0200
commita5c86aa0fbb8a9fa7f5e1b79d652df54ff83229c (patch)
treeb78e9dc0f6fd662aa97cd051ec334077355f959a /gnu/packages/tcl.scm
parentd9d836c3231be0122355f42f52f6779d07776720 (diff)
downloadguix-patches-a5c86aa0fbb8a9fa7f5e1b79d652df54ff83229c.tar
guix-patches-a5c86aa0fbb8a9fa7f5e1b79d652df54ff83229c.tar.gz
gnu: Add go-github.com-nsf-gothic.
* gnu/packages/tcl.scm (go-github.com-nsf-gothic): New variable.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 2d4001d288..4840ac4e10 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -381,3 +381,30 @@ application development. TclX provides additional interfaces to the operating
system, and adds many new programming constructs, text manipulation tools, and
debugging tools.")
(license license:tcl/tk)))
+
+(define-public go-github.com-nsf-gothic
+ (let ((commit "97dfcc195b9de36c911a69a6ec2b5b2659c05652")
+ (revision "0"))
+ (package
+ (name "go-github.com-nsf-gothic")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nsf/gothic")
+ (commit commit)))
+ (sha256
+ (base32
+ "1lrhbml6r4sh22rrn3m9bck70pv0g0c1diprg7cil90x0jidxczr"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/nsf/gothic"))
+ (propagated-inputs
+ `(("tk" ,tk)
+ ("tcl" ,tcl)))
+ (home-page "https://github.com/nsf/gothic")
+ (synopsis "Tcl/Tk Go bindings")
+ (description "Gothic contains Go bindings for Tcl/Tk. The package contains
+only one type and one function that can be used to create a Tk interpreter.")
+ (license license:expat))))