summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 09:51:56 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 09:51:56 +0100
commit8a0e29d8b9da4a277c8f9613be85df16de9e8898 (patch)
treeb21cf3410daec6b60a6f5671325d80609b72a758 /gnu/packages/tcl.scm
parent8166b6afe5e28d64d3ffd426a8153a980e2692b0 (diff)
downloadguix-patches-8a0e29d8b9da4a277c8f9613be85df16de9e8898.tar
guix-patches-8a0e29d8b9da4a277c8f9613be85df16de9e8898.tar.gz
gnu: tcl: Fix cross-compilation.
* gnu/packages/patches/tcl-fix-cross-compilation.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/tcl.scm (tcl): Apply it.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 7531c1ca9d..c88d0338cb 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,8 @@
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
- "1vc7imilx6kcb5319r7hnrp4jn5pqb41an3vr3azhgcfcgvdp5ji"))))
+ "1vc7imilx6kcb5319r7hnrp4jn5pqb41an3vr3azhgcfcgvdp5ji"))
+ (patches (search-patches "tcl-fix-cross-compilation.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases