summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-06 15:18:52 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-06 15:23:07 +0200
commit8079bd3da8eb5c185b447e2e1f89bb42f052f3cf (patch)
tree0a152eb7e0ef519a28aeeb07353a55dcfe25de43 /gnu/packages/tcl.scm
parent4a3f8994f42fbdb601e725bde648a765f70ed783 (diff)
downloadguix-patches-8079bd3da8eb5c185b447e2e1f89bb42f052f3cf.tar
guix-patches-8079bd3da8eb5c185b447e2e1f89bb42f052f3cf.tar.gz
gnu: tcl-tls: Use a gexp.
* gnu/packages/tcl.scm (tcl-tls)[arguments]: Use a gexp.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 9dceee7184..4cbc9d84b4 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -449,18 +449,17 @@ debugging tools.")
(inputs (list tcl))
(propagated-inputs (list openssl))
(arguments
- '(#:configure-flags
- (let ((out (assoc-ref %outputs "out"))
- (tcl (assoc-ref %build-inputs "tcl"))
- (ssllib (assoc-ref %build-inputs "openssl")))
- (list "--with-ssl=libressl"
- (string-append "-with-ssl-dir=" ssllib)
- (string-append "--with-tcl=" tcl "/lib")
- (string-append "--with-tclinclude=" tcl "/include")
- (string-append "--exec-prefix=" out)
- (string-append "--mandir=" out "/share/man")))
+ (list #:configure-flags
+ #~(let ((tcl #$(this-package-input "tcl")))
+ (list "--with-ssl=libressl"
+ (string-append "-with-ssl-dir="
+ #$(this-package-input "openssl"))
+ (string-append "--with-tcl=" tcl "/lib")
+ (string-append "--with-tclinclude=" tcl "/include")
+ (string-append "--exec-prefix=" #$output)
+ (string-append "--mandir=" #$output "/share/man")))
- #:test-target "test"))
+ #:test-target "test"))
(search-paths
(list (search-path-specification
(variable "TCLLIBPATH")