summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:51:50 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:47 -0400
commit6fea8adec913f29e20acc50b6e2f24341790ce50 (patch)
tree2ace32fd9ae35096b2f198f779f32422f6450176 /gnu/packages/tcl.scm
parent6d0f26123780f665f03e70a5f29d1e3e71b4d2cb (diff)
downloadguix-patches-6fea8adec913f29e20acc50b6e2f24341790ce50.tar
guix-patches-6fea8adec913f29e20acc50b6e2f24341790ce50.tar.gz
gnu: tcl: Use invoke.
* gnu/packages/tcl.scm (tcl)[arguments]: Use invoke and remove vestigial plumbing in the 'install-private-headers' phase.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 19b2bbf389..ef78e57cd7 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -55,16 +55,15 @@
(add-after 'install 'install-private-headers
(lambda* (#:key outputs #:allow-other-keys)
;; Private headers are needed by Expect.
- (and (zero? (system* "make"
- "install-private-headers"))
- (let ((bin (string-append (assoc-ref outputs "out")
- "/bin")))
- ;; Create a tclsh -> tclsh8.6 symlink.
- ;; Programs such as Ghostscript rely on it.
- (with-directory-excursion bin
- (symlink (car (find-files "." "tclsh"))
- "tclsh"))
- #t)))))
+ (invoke "make" "install-private-headers")
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ ;; Create a tclsh -> tclsh8.6 symlink.
+ ;; Programs such as Ghostscript rely on it.
+ (with-directory-excursion bin
+ (symlink (car (find-files "." "tclsh"))
+ "tclsh"))
+ #t))))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is