summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-02-13 00:27:17 +0100
committerLeo Famulari <leo@famulari.name>2016-02-12 19:13:05 -0500
commit511539ae81100146d03575f41abda7d72d3000e0 (patch)
treef27e737994623cb1ee32fc91f80447090a38ab06 /gnu/packages/tcl.scm
parent6cefd53d3e83e7159fca1a0d8653e8cf8b7176fa (diff)
downloadguix-patches-511539ae81100146d03575f41abda7d72d3000e0.tar
guix-patches-511539ae81100146d03575f41abda7d72d3000e0.tar.gz
gnu: Add tclxml.
* gnu/packages/patches/tclxml-3.2-install.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/tcl.scm (tclxml): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index d98d2d619a..1f301458a9 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix licenses))
@@ -244,3 +245,48 @@ interfaces (GUIs) in the Tcl language.")
(description "Tcllib, the standard Tcl library, is a collection of common
utility functions and modules all written in high-level Tcl.")
(license (package-license tcl))))
+
+(define-public tclxml
+ (package
+ (name "tclxml")
+ (version "3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ffb4aw63inig3aql33g4pk0kjk14dv238anp1scwjdjh1k6n4gl"))
+ (patches (list (search-patch "tclxml-3.2-install.patch")))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("tcl" ,tcl)
+ ("tcllib" ,tcllib)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TCLLIBPATH")
+ (separator " ")
+ (files (list (string-append "lib/Tclxml" version))))))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--exec-prefix=" (assoc-ref %outputs "out"))
+ (string-append "--with-tclconfig="
+ (assoc-ref %build-inputs "tcl") "/lib")
+ (string-append "--with-xml2-config="
+ (assoc-ref %build-inputs "libxml2")
+ "/bin/xml2-config")
+ (string-append "--with-xslt-config="
+ (assoc-ref %build-inputs "libxslt")
+ "/bin/xslt-config"))
+ #:test-target "test"))
+ (home-page "http://tclxml.sourceforge.net/")
+ (synopsis "Tcl library for XML parsing")
+ (description "TclXML provides event-based parsing of XML documents. The
+application may register callback scripts for certain document features, and
+when the parser encounters those features while parsing the document the
+callback is evaluated.")
+ (license (non-copyleft
+ "file://LICENCE"
+ "See LICENCE in the distribution."))))