summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-16 22:39:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-16 22:39:52 +0300
commit49b92a24144b207170703fd09036e893d933997f (patch)
tree0b77595612feafead7de0cec87042df916133e4e /gnu/packages/tcl.scm
parent9bb98f6425f2d9bd45a7dd432b2480e5a8cb7306 (diff)
downloadguix-patches-49b92a24144b207170703fd09036e893d933997f.tar
guix-patches-49b92a24144b207170703fd09036e893d933997f.tar.gz
gnu: tk: Add symlink for 'wish' binary.
* gnu/packages/tcl.scm (tk)[arguments]: Add custom phase to create a symlink from 'wish' to 'wish8.6'. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 97e1427bec..06f4f9bb58 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -25,6 +25,7 @@
(define-module (gnu packages tcl)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (gnu packages)
@@ -145,13 +146,22 @@ X11 GUIs.")
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-before
'configure 'pre-configure
(lambda _
(chdir "unix")
#t))
(add-after
+ 'install 'create-wish-symlink
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (symlink (string-append out "/bin/wish"
+ ,(version-major+minor
+ (package-version tk)))
+ (string-append out "/bin/wish")))
+ #t))
+ (add-after
'install 'add-fontconfig-flag
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Add the missing -L flag for Fontconfig in 'tk.pc' and
@@ -179,7 +189,7 @@ X11 GUIs.")
(propagated-inputs `(("libx11" ,libx11)
("libxext" ,libxext)))
- (home-page "http://www.tcl.tk/")
+ (home-page "https://www.tcl.tk/")
(synopsis "Graphical user interface toolkit for Tcl")
(description
"Tk is a graphical toolkit for building graphical user