summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-02-25 18:54:39 -0500
committerKei Kebreau <kei@openmailbox.org>2017-04-10 17:29:07 -0400
commit0ef83ec9d0d98cecf682c426e3ed10da5f2d4c1a (patch)
tree5311b8de7ad40cf4201a6bf14c63974eb19d20e1 /gnu/packages/tcl.scm
parentd81f131ff8472652cd9132fe885455eb4e2bdbcd (diff)
downloadguix-patches-0ef83ec9d0d98cecf682c426e3ed10da5f2d4c1a.tar
guix-patches-0ef83ec9d0d98cecf682c426e3ed10da5f2d4c1a.tar.gz
gnu: Add tclx.
* gnu/packages/tcl.scm (tclx): New variable.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index f9a23c3230..adad55e2da 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -290,3 +291,35 @@ callback is evaluated.")
(license (non-copyleft
"file://LICENCE"
"See LICENCE in the distribution."))))
+
+(define-public tclx
+ (package
+ (name "tclx")
+ (version "8.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/tclx/TclX/"
+ version "/tclx" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1v2qwzzidz0is58fd1p7wfdbscxm3ip2wlbqkj5jdhf6drh1zd59"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; a test named profile.test segfaults
+ #:configure-flags (list (string-append "--with-tcl="
+ (assoc-ref %build-inputs "tcl")
+ "/lib")
+ (string-append "--libdir="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (inputs
+ `(("tcl" ,tcl)
+ ("tk" ,tk)))
+ (home-page "http://tclx.sourceforge.net/")
+ (synopsis "System programming extensions for Tcl")
+ (description
+ "Extended Tcl is oriented towards system programming tasks and large
+application development. TclX provides additional interfaces to the operating
+system, and adds many new programming constructs, text manipulation tools, and
+debugging tools.")
+ (license tcl/tk)))