summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-10 20:56:44 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-10 21:39:05 +0200
commite4b02e7e395f6b21126edc5e82071ce05bd3c24a (patch)
tree0692c9b4a2ded3b1e798e21899b68e529a0a4df7 /gnu/packages/tbb.scm
parent45055c73c8a6db7d47aca1fdac991ee772f3fab8 (diff)
downloadguix-patches-e4b02e7e395f6b21126edc5e82071ce05bd3c24a.tar
guix-patches-e4b02e7e395f6b21126edc5e82071ce05bd3c24a.tar.gz
gnu: tbb: Update to 2021.3.0.
* gnu/packages/tbb.scm (tbb): Update to 2021.3.0. [source]: Update repository URL. Remove snippet. [build-system]: Switch to 'cmake-build-system'. [arguments]: Add 'configure-flags'. Remove 'make-flags'. Remove 'fail-on-test-errors' phase. Remove custom 'configure' and 'install' phases.
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm67
1 files changed, 7 insertions, 60 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 5f1438667d..2aa31225df 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,79 +24,25 @@
#:use-module (guix licenses)
#:use-module (guix git-download)
#:use-module (guix utils)
- #:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (gnu packages))
(define-public tbb
(package
(name "tbb")
- (version "2020.3")
+ (version "2021.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/01org/tbb")
+ (url "https://github.com/oneapi-src/oneTBB")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0r9axsdlmacjlcnax4vkzg86nwf8lsx7wbqdi3wnryaxk0xvdcx6"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "build/common.inc"
- (("export tbb_build_prefix.+$")
- "export tbb_build_prefix?=guix\n"))
-
- ;; Don't capture the build time and kernel version.
- (substitute* "build/version_info_linux.sh"
- (("uname -srv") "uname -s")
- (("`date -u`") "01 Jan 1970"))
-
- (substitute* "build/linux.inc"
- (("os_kernel_version:=.*")
- "os_kernel_version:=5\n")
- (("os_version:=.*")
- "os_version:=1\n"))
- #t))))
- (outputs '("out" "doc"))
- (build-system gnu-build-system)
+ "1bz039my3ma87f24ngcsqs16f8jlpdgaqg01ab4g60nfqbrz1lkq"))))
+ (build-system cmake-build-system)
(arguments
- `(#:test-target "test"
- #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fail-on-test-errors
- (lambda _
- (substitute* "Makefile"
- (("-\\$\\(MAKE") "$(MAKE"))
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "build/linux.gcc.inc"
- (("LIB_LINK_FLAGS =")
- (string-append "LIB_LINK_FLAGS = -Wl,-rpath="
- (assoc-ref outputs "out") "/lib")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((doc (string-append
- (assoc-ref outputs "doc") "/doc"))
- (examples (string-append doc "/examples"))
- (lib (string-append
- (assoc-ref outputs "out") "/lib"))
- (include (string-append
- (assoc-ref outputs "out") "/include")))
- (mkdir-p lib)
- (for-each
- (lambda (f)
- (copy-file f
- (string-append lib "/"
- (basename f))))
- (find-files "build/guix_release" "\\.so"))
- (copy-recursively "doc" doc)
- (copy-recursively "examples" examples)
- (copy-recursively "include" include)
- #t))))))
+ `(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings
(home-page "https://www.threadingbuildingblocks.org")
(synopsis "C++ library for parallel programming")
(description