summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-23 00:50:53 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:47 -0500
commitc61e742854c4c81b25bf6c249dd748477a1ffed8 (patch)
tree2d667f7bda9d8e5f2cdc2bb0c746538f0399914d /gnu/packages/tbb.scm
parent5651e46983866024fe1df4fa4feafd4d30b99c4c (diff)
downloadguix-patches-c61e742854c4c81b25bf6c249dd748477a1ffed8.tar
guix-patches-c61e742854c4c81b25bf6c249dd748477a1ffed8.tar.gz
gnu: tbb-2020: Use ld.gold to work around segfaults in check phase.
* gnu/packages/tbb.scm (tbb-2020) [configure-flags]: Use -fuse-ld=gold in CFLAGS. [native-inputs]: Add ld-gold-wrapper.
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 427f281686..e5d8394f5f 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -89,7 +89,8 @@ tasks, synchronization primitives, atomic operations, and more.")
(arguments
`(#:test-target "test"
#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))
+ (assoc-ref %outputs "out") "/lib")
+ "CFLAGS=-fuse-ld=gold")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fail-on-test-errors
@@ -121,6 +122,13 @@ tasks, synchronization primitives, atomic operations, and more.")
(copy-recursively "doc" doc)
(copy-recursively "examples" examples)
(copy-recursively "include" include)))))))
+ (native-inputs
+ ;; XXX: For some reason, since commit "gnu: binutils: Absorb
+ ;; binutils-next", the build of just this version of TBB crashes during
+ ;; tests. Workaround it by linking the binaries with ld.gold.
+ (list (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-gold-wrapper)))
(home-page "https://www.threadingbuildingblocks.org")
(synopsis "C++ library for parallel programming")
(description